Mtbr's 2016 Winter Biking GearReviews and Roundups

FAT BIKES

WINTER APPAREL

TRAINERS

Results 1 to 8 of 8
  1. #1
    mtbr member
    Reputation:
    Join Date
    Sep 2004
    Posts
    573

    garmin 510 iphone bluetooth sync issues

    When syncing the Garmin 510 with an iPhone 6 running IOS 9.0.1 and Garmin Connect, the bluetooth pairing occurs and Connect displays "syncing with unit" or whatever, as it usually does, but then a second later that goes away and it apparently doesn't pull over the latest ride.

    The two reasons I upgraded to the 510 from the 500 were improved GPS accuracy, which it has, and the bluetooth feature, which for the past month has not worked at all.

    Am I the only one? Do I have a defective unit? Garmin has not been responsive.

  2. #2
    mtbr member
    Reputation: WR304's Avatar
    Join Date
    Jul 2004
    Posts
    4,475
    If it's only in the last month would that timing be around the same as when you updated your iPhone 6 from IOS 8 to IOS 9?

    There's a newer IOS 9.0.2 update available so you could try installing that on your phone. It doesn't mention anything specifically about bluetooth changes though.

    Are you running the newest Garmin Connect app version? Version 2.14 of the IOS Garmin Connect app (24 September 2015) lists bluetooth sync fixes in its changelog.

    There's also a new 4.30 firmware version that has just been released for the Garmin Edge 510. It could be worth trying updating to that too.

    Have you tried closing all the background apps on your iPhone 6 (double tap the home button and then swipe up on each app in turn to close them all). That can sometimes help with connectivity issues if you only have the Garmin Connect app running by itself when syncing.

    Have you tried manually deleting all existing .fit ride files off the Garmin Edge 510, so that when you sync it there is just a single recent .fit ride file. If you have lots of historic files there may be a bad .fit file or a file conflict among them that is stopping the Garmin from syncing properly for some reason.

  3. #3
    since 4/10/2009
    Reputation: Harold's Avatar
    Join Date
    Dec 2003
    Posts
    16,459
    every Garmin I know of needs to be cleared/reset periodically. Once the history packs up, they start behaving unpredictably.

  4. #4
    mtbr member
    Reputation:
    Join Date
    Apr 2005
    Posts
    1,412
    I have already had my rant on this.

    It is broken.

    After almost a year, garmin is finally acknowledging that it is broken.

    They are blaming apple, but cannot explain how the same app works with the 520 with no issue (FYI they are blaming it on the app, not the unit; my guess is to keep them from having to replace units).

    They claim they are working on a solution but to date have not delivered one.

    My recommendations are:
    1. Make sure it is updated with the latest firmware on the device and app on your phone
    2. Go into the activities folder on the device and delete all of the .fit activities
    3. Delete the device pairing on the iPhone app and re-pair the two

    This will probably help somewhat, but it will not ultimately resolve the problem.
    Austin Mountain Biking and worldwide travel pictures:

    http://www.austinbike.com

  5. #5
    mtbr member
    Reputation:
    Join Date
    Sep 2004
    Posts
    573
    Thanks for the advice. Did not work. Really annoyed.


    Sent from my iPhone using Tapatalk

  6. #6
    mtbr member
    Reputation:
    Join Date
    Apr 2005
    Posts
    1,412
    Get in line. Garmin has hosed this one hard.
    Austin Mountain Biking and worldwide travel pictures:

    http://www.austinbike.com

  7. #7
    since 4/10/2009
    Reputation: Harold's Avatar
    Join Date
    Dec 2003
    Posts
    16,459
    My recommendation is not to use app connectivity and just plug the stupid thing into the computer to do data transfers

  8. #8
    mtbr member
    Reputation:
    Join Date
    Sep 2004
    Posts
    573
    I *almost* circled back here the other day to share that the latest update from Garmin corrected the issue. Syncing with Bluetooth worked great for three weeks. Then it spontaneously decided to stop working, again. So.....

Similar Threads

  1. garmin 510 app sync problems
    By dnoyeb in forum GPS, HRM and Bike Computer
    Replies: 2
    Last Post: 08-27-2014, 10:08 AM
  2. Auto sync for Garmin to Strava is now here
    By heyyall in forum GPS, HRM and Bike Computer
    Replies: 24
    Last Post: 08-14-2014, 12:10 PM
  3. Will a Bluetooth speed sensor improve iPhone 5 gps accuracy?
    By Ozzy43 in forum GPS, HRM and Bike Computer
    Replies: 10
    Last Post: 08-05-2014, 04:35 PM
  4. iPhone 5 and Garmin 510 bluetooth issues
    By fongster in forum GPS, HRM and Bike Computer
    Replies: 13
    Last Post: 07-18-2014, 03:55 PM
  5. Any Bluetooth HRM devices that work with iPhone?
    By desert guy in forum GPS, HRM and Bike Computer
    Replies: 12
    Last Post: 01-14-2013, 09:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Follow MTBR on Facebook