Results 1 to 6 of 6
  1. #1
    mtbr member
    Reputation: dirtbiker's Avatar
    Join Date
    Jan 2005
    Posts
    634

    Garmin 305 went DEAD

    I bought a Garmin 305 this year with the HRM, well I have never been able to get the HRM to work as I posted in another thread, now all of a sudden the GPS has stopped working altogether. It was charging on my computer, I went to take it off and now I have nothing. What could this be? There is no display at all and when plugged in it no longer displays charge in session. HELP.
    2015 SC Tallboy C
    2013 SC TRC
    2014 Heckler
    2014 Bronson C

  2. #2
    GeoMan
    Reputation: GEOMAN's Avatar
    Join Date
    May 2006
    Posts
    1,707
    Press and hold BOTH the MODE and LAP/RESET buttons for a few seconds, release, and power it up to perform a "soft reset". You suffered a 'charge spike'.
    GeoMan
    We Ride!
    www.geomangear.com

  3. #3
    mtbr member
    Reputation: dirtbiker's Avatar
    Join Date
    Jan 2005
    Posts
    634
    Thanks geoman, that did the trick.
    2015 SC Tallboy C
    2013 SC TRC
    2014 Heckler
    2014 Bronson C

  4. #4
    mtbr member
    Reputation:
    Join Date
    Jul 2007
    Posts
    5
    Thanks geoman, suffering the same problem about a hour ago and decide to bite the bullet and get a 705, so was reading the forum when stumbled upon this threat....you just save me few hundred bucks, greatly appreciated.

  5. #5
    GeoMan
    Reputation: GEOMAN's Avatar
    Join Date
    May 2006
    Posts
    1,707
    Quote Originally Posted by Munich888
    Thanks geoman, suffering the same problem about a hour ago and decide to bite the bullet and get a 705, so was reading the forum when stumbled upon this threat....you just save me few hundred bucks, greatly appreciated.
    That's why we're here!

    Thanks!!!
    GeoMan
    We Ride!
    www.geomangear.com

  6. #6
    nOOb
    Reputation:
    Join Date
    May 2008
    Posts
    399
    How timely, my 305 did the same thing yesterday after my ride. Somehow the battery got completely discharged overnight, so I had a dickens of a time getting it to charge. It also won't download yesterday's ride data, but it shows up in the unit itself. I have replaced all 4 of my bikes computers with gps mounts, I hope it doesn't die on me in the middle of the season!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •