Results 1 to 3 of 3
  1. #1
    mtbr member
    Reputation: wvmtb's Avatar
    Join Date
    Jan 2004
    Posts
    438

    Elevations with my Edge 305

    I did a race a while back and when I uploaded my data to strava from my edge 305 my elevations were way off compared to everyone else that uploaded their race data using all sorts of devices.

    Yesterday I rode a trail that I ride a lot and usually get about 1800' of elevation gain on it. This time it showed I had almost 2700' of gain. I have the the strava app on my phone and just for the fun of it I ran it along with my edge and it showed the same distance but with the normal/expected 1800' of gain.

    Anyone know why all of a sudden my edge is altimeter is off by so much? Could it be going bad?
    uʍop əpıs ɹəqqnɹ əɥʇ dəəʞ ɹəqɯəɯəɹ pəɥsɐɹɔ əʌɐɥ ʇɥƃıɯ noʎ sıɥʇ pɐəɹ uɐɔ noʎ ɟı

  2. #2
    mtbr member
    Reputation:
    Join Date
    Jan 2004
    Posts
    1,918

    Mine is usually the other way.

    When you upload to strava or G connect they usually calculate elevation change based thier own data which is supposed to be more accurate then the altimiter. Usually my Edge records less climbing then strava.
    Visiting St george/Hurricane? Stay at my vacation rental. Discounts for MTB's

    http://www.vrbo.com/392904

    PM me

  3. #3
    Rep Power: Infinity
    Reputation: NateHawk's Avatar
    Join Date
    Dec 2003
    Posts
    11,903
    check that the little hole on the back of the case (the opening for the barometer) isn't plugged with dirt.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •