Results 1 to 5 of 5

Thread: Edge 305 HR

  1. #1
    KAH
    KAH is offline
    mtbr member
    Reputation:
    Join Date
    Mar 2006
    Posts
    73

    Edge 305 HR

    I'm sure it's something obvious, but I can't get my HR to show. It's picking up because it's not flashing heart/X but the HR isn't showing. My profile and zones are loaded. What obvious "duh" am I missing?

  2. #2
    Silence! I kill you!
    Reputation: jorgemonkey's Avatar
    Join Date
    Mar 2004
    Posts
    2,820
    Go into the data fields, and change one of them to show the HR. I'd pull up the info on how, but I don't have my GPS with me.
    My Website:
    Scott Mosher Photography

    My Recent Shoots
    The Blog

  3. #3
    mtbr member
    Reputation:
    Join Date
    Jan 2005
    Posts
    43
    He's right...onve you upload your data to the garmin training center, you will see the elvation graph in the bottom half of the screen. There are four little boxes on the upper corners. One of them has to be set to heart rate to show the results. Try that.

  4. #4
    KAH
    KAH is offline
    mtbr member
    Reputation:
    Join Date
    Mar 2006
    Posts
    73
    Thanks, I'll give that a try.

  5. #5
    Team Cspine
    Reputation: bulletbob's Avatar
    Join Date
    Apr 2004
    Posts
    492
    Followup to KAH...

    I can't get mine to show up either, all I get are the 8 default data fields.

    DOh!! Operator error, nevermind!
    Sorry what?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •