Results 1 to 5 of 5
  1. #1
    mtbr member
    Reputation:
    Join Date
    Feb 2007
    Posts
    53

    Linkage/Bearing Squeak on Anthem 29

    My '11 Anthem 29 has about 5-8 rides now and has developed a really annoying squeak. At first I thought it was a stuck link in the chain, but when I bounce on the bike just a little it squeaks.

    I checked the rear lower/main pivot bolt and it was crazy loose, like 3 full turns to tighten it back but that didn't fix it.

    Any ideas? I've heard there are common bearing issues out of the factory on these, so hoping it's not that.

  2. #2
    mtbr member
    Reputation:
    Join Date
    Feb 2004
    Posts
    783
    is in not under warranty? Take it back to where you bought it and let them check it out. You don't want to screw anything up, and then have them deny a warranty claim.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Feb 2007
    Posts
    53
    it is but i live 45min from there, then drop it off, wait however long, drive back to hope they fixed it. I typically work on my own stuff as a result.

    Anyone have any actual knowledge to share?

  4. #4
    mtbr member
    Reputation:
    Join Date
    Feb 2004
    Posts
    783
    Quote Originally Posted by ibrown View Post

    Anyone have any actual knowledge to share?
    well, since you put it that way............................................... ......NO!

  5. #5
    mtbr member
    Reputation:
    Join Date
    Jun 2006
    Posts
    318
    Check the DU bushings on the shock. I've often tracked unwanted noises to these, even on new bikes (not Giant specific).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •