Results 1 to 3 of 3
  1. #1
    weekend warrior
    Reputation:
    Join Date
    Jul 2008
    Posts
    22

    bottom bracket problems on the sugar 3+

    ever since i found my sugar 3 frame and built it up.. it always had the loose bottom bracket noise (every time the pedals go round a loud "CLACK" is heard eminating from the region of the frame that holds the bottom bracket) i have read from sheldon browns site what causes this and how to fix it however i have "fixed" it 3 times. and every time it has come back and with a vengance.

    my last method was take it out, clean it all out inside, spray lithium grease inside, clean off the threads real good and put a small amount of blue threadlocker on it and reinstall it. about 100 miles later it comes loose again.

    does anyone know how to solve this problem once and for all? or have they had this problem too? it seems only my fishers have this problem (my sugar and hookooekoo)
    the path to awesomeness... is a bike path

  2. #2
    mtbr member
    Reputation:
    Join Date
    May 2004
    Posts
    1,593
    I don't think that's a Fisher problem, at least not the ones I've ridden in the past.

  3. #3
    mtbr member
    Reputation: MikeDee's Avatar
    Join Date
    Nov 2004
    Posts
    1,106
    Try the blue loctite again, but degrease the threads and use a lot more of it. Are you sure it is coming loose? If it isn't loose, try antiseize compound. Also, teflon tape is supposed to work.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •