• 10-02-2012
    J3SSEB
    TRUVATIV self extracting bolt woes
    I'm at my wits end people. My TRUVATIV Stylo carbon crank (06 model) recently came loose. When I went to tighten it I heard a pop and the wrench continued to spin. I took the left arm apart, including the self extracting bolt and cap only to find that the bolt was stripped. No problem. I had another laying around which I tried to put on with the same results, plus it broke. I looked at the spindle and that looks good, but for some reason the bolts keep getting stripped. I'm not using a torque wrench, but I'm also not tightening beyond the crank being snug. So basically the crank never gets tight enough no matter how much pressure I apply and then the bolt strips or breaks. Any ideas oh mighty crank masters?

    I'm using a truvativ stylo high modulus carbon crank with an external gxp bb.
  • 10-03-2012
    Kristatos
    The only thing I can think is that the fixing bolt on the left crank which attaches it to the spindle/right crank assembly is bottoming out before the crank tightens all the way. Maybe part of the old bolt is still deep down in those threads, preventing the new bolt from getting in there all the way? As long as the cups, cranks and seals are all assembled properly that's the only thing I can think of.
  • 10-03-2012
    J3SSEB
    Quote:

    Originally Posted by Kristatos View Post
    The only thing I can think is that the fixing bolt on the left crank which attaches it to the spindle/right crank assembly is bottoming out before the crank tightens all the way. Maybe part of the old bolt is still deep down in those threads, preventing the new bolt from getting in there all the way? As long as the cups, cranks and seals are all assembled properly that's the only thing I can think of.

    Yeah, I made sure to clean out the spindle really well before installing the new bolt, and as far as I know the crank components are all installed properly. Im at the point of buying a new crank set.