Results 1 to 2 of 2
  1. #1
    mtbr member
    Reputation:
    Join Date
    Jun 2007
    Posts
    39

    Truvativ Hussefelt 1.1 Crank set 2006 Problem..

    I bought a Truvativ Hussefelt 1.1 Crank set 2006 and using a Truvativ Gigapipe Team DH bottom bracket

    I tighten it on the manufactured the spindle bolt @ the recommended specs after bouncing around in front of my hose I notice that my right crank arm were the chain ring is. Were loose and I tried to re tighten it again and it was still loose. what do you guys thinks is wrong on my crank this is a brand new set and just put it last night and even how hard I torque them it still have a play on the crank bolt spindle. Could this be a manufactured defect?

    I never seen any problem like this before feels like my bottom bracket spindle is too small for my right crank arm. They wobble even how tight I torque the M12 bolt But my left crank is very intact and solid no movement just the right arm

    Please help suggestions..

  2. #2
    Your bike is incorrigible
    Reputation: Guyechka's Avatar
    Join Date
    Jul 2005
    Posts
    3,133
    Quote Originally Posted by GravityD
    I bought a Truvativ Hussefelt 1.1 Crank set 2006 and using a Truvativ Gigapipe Team DH bottom bracket

    I tighten it on the manufactured the spindle bolt @ the recommended specs after bouncing around in front of my hose I notice that my right crank arm were the chain ring is. Were loose and I tried to re tighten it again and it was still loose. what do you guys thinks is wrong on my crank this is a brand new set and just put it last night and even how hard I torque them it still have a play on the crank bolt spindle. Could this be a manufactured defect?

    I never seen any problem like this before feels like my bottom bracket spindle is too small for my right crank arm. They wobble even how tight I torque the M12 bolt But my left crank is very intact and solid no movement just the right arm

    Please help suggestions..
    I had some Hussefelts that were coming loose on the drive side, too. In fact, I sent the drive side crank back and had it replaced because the splines became stripped. When I got the new one, I removed all grease from inside the spindle and the bolt, and I squirted some red loctite in there. It didn't come loose after that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •