Results 1 to 3 of 3
  1. #1
    mtbr member
    Reputation: flipnidaho's Avatar
    Join Date
    Aug 2004
    Posts
    6,418

    SRAM X9 Trigger indexing question

    I have SRAM X9 Trigger shifters (I think they're 06's) and the shift to smaller cogs have a nice positive click but shifting to a lower gear/larger cog has no discernible click or index (it feels a lot like friction shifting). Is this normal? It is taking me a while to get used to it and I end up overshifting sometimes. The rear derailleur is an X0.
    Thanks

  2. #2
    mtbr member
    Reputation:
    Join Date
    Nov 2005
    Posts
    3
    Quote Originally Posted by flipnidaho
    I have SRAM X9 Trigger shifters (I think they're 06's) and the shift to smaller cogs have a nice positive click but shifting to a lower gear/larger cog has no discernible click or index (it feels a lot like friction shifting). Is this normal? It is taking me a while to get used to it and I end up overshifting sometimes. The rear derailleur is an X0.
    Thanks

    No discernable click is not normal.

    I have the same shifters and while the downshift click is very muted there is still a noticable click. The downshift click is certainly not as obvious as the upshift click. When you hit that upshift button you KNOW you have done something.

  3. #3
    banned
    Reputation: Jerk_Chicken's Avatar
    Join Date
    Oct 2005
    Posts
    16,480
    If they are new, let them break in.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •