• 09-04-2012
    joe_soma
    SRAM type 2 derailleur issues
    Hey All:

    I've been running an X9 type 2 derailleur for around 3 weeks now. Everything you've read is true: chain slap is nearly eliminated and the frequency of dropped chains is reduced (at least compared to a SRAM xx 2x10 rear der.) BUT, I've developed a strange and irritating issue:

    The clutch seems to have fallen out of tune or something. It takes a significant force to overcome the clutch at this point. When the cage finally moves forward I hear a fairly loud click. I hear this click every time I cycle past 40% travel in the rear. I can also feel this force in the suspension travel. I've been riding primarily dusty terrain. I was caught in a biblical rain storm about a week ago. Anyone else discover similar issues? Is the clutch adjustable (i don't think so)?
  • 09-05-2012
    Darkstar187
    It seems you aren't the only one having issues with the type 2 derailleur! I had issues with my clutch being way to tight keeping the bike from shifting correctly. For the time being i think the type 2 is a flop. i sent mine in for warranty. I am now using Shimano Zee derailleur and saint shifter. The clutch is not adjustable.

    http://forums.mtbr.com/drivetrain-sh...ms-807541.html
  • 09-05-2012
    in the trees
    More info on this. I was about to invest in a Type2.
  • 09-05-2012
    joe_soma
    I would wait. My bike shifts fine and it is much quieter but the very slight hesitation I feel/hear in my suspension travel is really troubling. I think the source of my issues may have been a really intense rainstorm. I spoke to SRAM today. They are looking into it. Also of note - I'm not an anal mtb owner. I ride a lot and I do an average amount of maintenance. I'm accustomed to some occasional noise from my ride.
  • 09-05-2012
    KVW
    Damn, I'm really interested in one of these derailleurs. Amazon has em for a decent price too. Prime shipping, no tax - was just bout to pull the trig when I decided i should do a few searches first. Guess this is the price of being an early adopter. Hope they work out these issues quick!
  • 09-06-2012
    tracerprix
    This is upsetting, I just bought a X.0 type 2, hmmm I'll try it anyway.
  • 09-06-2012
    joe_soma
    Following up, a friend sent me this link to a thread on bikeradar:

    BikeRadar.com • View topic - SRAM type 2
    *
    This guy is having the exact same problem that I am.
  • 09-17-2012
    tree_trunks
    joe_soma:

    Thanks for the BikeRadar link!

    My type 2 is having the exact same issue after 2 weeks in dusty condistions. It started out with a slight knock. Then it progressed to a louder knock and could be felt everytime the suspension moved. I took the shock off and cycled the suspension... it didn't matter which gear or at what point the susp was cycled. On initial up movement, every gear produced the knock/ clunk.

    SRAM customer service had very different answers from Friday to today... The first rep I talked to said it was obviously an issue. The rep today would only discuss through a bike shop mechanic and they tried to imply that the new derailleur has a different cage length capacity than previous SRAM derailleurs.

    Even worse: I have XTR Shadow Plus in its place now that performs flawlessly! I like the SRAM lever action, but the clutch does not seem ready for "primetime." Early adoption strikes again :madman:
  • 09-18-2012
    NH Mtbiker
    Hmm.... I was ready to get the X9 also as I have X7 triggers already. Can I still get an XT Shadow and run the X7 triggers?... or will I need to go all Shimano? Looking to just set it up as a 1 x 10 for the rear using the short cage. 34T Bling ring with a 12/36 cassette. :madman:
  • 09-18-2012
    tracerprix
    Your shifters need to match your rd. so if you have shimano rd you need shimano shifters same goes for SRAM. I think the reason being they each have a different shift length when you shift te shifters so the rd wouldn't shift right of you mismatched them. Make sense?
  • 09-18-2012
    sanjosedre
    Thank you guys for sharing your experiences, I was about to dive in.

    Dre
  • 09-19-2012
    ncfisherman
    Quote:

    Originally Posted by tree_trunks View Post
    Even worse: I have XTR Shadow Plus in its place now that performs flawlessly! I like the SRAM lever action, but the clutch does not seem ready for "primetime." Early adoption strikes again :madman:

    So glad that I went the XT Plus route instead of X0. I like that the Shimano clutch system is easily accessible/adjustable.
  • 09-19-2012
    bad andy
    I may be experiencing this too. New bike came with x9 Type2 and have noticed a "notch point" during suspension movement. Not audible, but can be felt through the stroke of the rear suspension. WIll update with findings during testing.
  • 09-21-2012
    benja55
    Glad I found this thread too. I was waiting for the silver/black colorways on the Type 2 (due Nov FYI) and now I'm glad I waited.

    I've come to really love the feel of SRAM XO shifting but really would like to go roller clutch rear der. Hope they get this sorted ASAP. It's clear Shimano put the work in on Shadow Plus. Everyone raves about it.
  • 09-25-2012
    bad andy
    Yup, just confirming after having more time to look into it. I can definitely feel the clutch threshold through my pedals when the rear suspension activates. Depending on which gear I am in on the cassette (due to chain tension) I can feel the notch at a varying point during the suspension travel. Sometimes I don't feel it at all, if the suspension isn't moving enough to reach the threshold to activate the clutch. Nonetheless I do notice it on occasion. Under riding conditions it is harder to detect, as truthfully I am paying more attention to the trail - but when I do notice while riding, it does kind of irk me. Hoping the clutch breaks in a bit and it becomes less noticeable. I don't want to outlay any cash to swap derailleurs or anything so at this point, I'm just saying F- it and riding the bike.
  • 09-25-2012
    testtech
    I just installed a medium cage type 2 X0 in place of a medium cage XX. 2x10 setup. Setting proper chain length for the small chain ring and small cog results in inadequate chain length for large chain ring and large cassette cogs. With 10 as the largest, when I shift to 8, the chain jams because there is not enough slack chain to lift onto the cog. If I then add a link, when I run small chain ring and small (#1) cassette cog, the chain/upper jockey wheel contacts moving chain. There is no chain length that works! How is this possible?
  • 09-28-2012
    phatfreeheeler
    Quote:

    Originally Posted by testtech View Post
    I just installed a medium cage type 2 X0 in place of a medium cage XX. 2x10 setup. Setting proper chain length for the small chain ring and small cog results in inadequate chain length for large chain ring and large cassette cogs. With 10 as the largest, when I shift to 8, the chain jams because there is not enough slack chain to lift onto the cog. If I then add a link, when I run small chain ring and small (#1) cassette cog, the chain/upper jockey wheel contacts moving chain. There is no chain length that works! How is this possible?

    XX is always long cage. Medium cage does not have quite enough travel for true 2x10 with the 11-36 cassette in the back, that's your issue.
  • 09-30-2012
    Hangtime
    I'm very glad I came across this thread. I was on the fence between XT and X9. Now I'm leaning to Shimano. So the long cage is the ticket for 11-36
  • 10-01-2012
    testtech
    Quote:

    Originally Posted by Hangtime View Post
    I'm very glad I came across this thread. I was on the fence between XT and X9. Now I'm leaning to Shimano. So the long cage is the ticket for 11-36

    My medium cage XO type 2 is now working flawlessly on 11-36. The original problems were the result of an installation error by the bike shop mechanic. All I got from this experience was that I will use a different bike shop;
  • 10-01-2012
    jon123
    I also have the knocking noise (X0 Type 2, medium cage). Exactly as joe_soma described: it's quite audible once you hit about 40% rear travel.
    I spoke with Sram today and (after initially claiming to be unaware of the problem) the rep said it is only noise and a) does not affect the suspension and b) will not harm the derailleur.
    Anyone have any further thoughts?
  • 10-01-2012
    bad andy
    I have some thoughts, though my thoughts don't usually amount to much. I am curious however, there seem to be no reports of this behavior affecting users of Shimano's clutch system so I wonder what is different mechanically about them. I know shimano's is user-adjustable to an extent but beyond that haven't seen one or felt one even.
  • 10-01-2012
    phatfreeheeler
    For the data point, I've got about a month on mine without this issue.
  • 10-30-2012
    dmode101
    My one month old Type2 medium cage is clicking now! You cant test yours by siting on your bike and and bouncing up and down to compress the rear suspension. I tried lubing all the pivot points on the Type2, no luck. Mine was initially quiet, so it's gotta be related to dusty trail riding, washing the bike or wear on the sealed clutch mechanism, Sram has got to be aware of this issue.
  • 10-31-2012
    in the trees
    Is the consensus to run a medium cage with an 11-36T cassette even with a 1x10 drivetrain?
  • 10-31-2012
    dmode101
    I'm running a medium Type2 cage on my 1x10 setup (11-36t x 34t) and I still get clicking.
  • 11-01-2012
    neilether
    Quote:

    Originally Posted by testtech View Post
    My medium cage XO type 2 is now working flawlessly on 11-36. The original problems were the result of an installation error by the bike shop mechanic. All I got from this experience was that I will use a different bike shop;

    My new x9 type 2 derailleur began knocking badly today. It ran really nicely for maybe 6-7 rides. Anyway, can you elaborate as to how it was installed incorrectly?
  • 11-08-2012
    yoeddy20000
    Im getting clicking noise as well from my type 2 do rear dérailleur, comes from the roller cam area. Derailleur works well, just makes noise.
  • 11-09-2012
    trhoppe
    My knocking/creaking issues were because the chain was too short. It seems that these derailleurs are more sensitive to a shorter chain. My bike (Trek Remedy) has lots of chain growth and I was measuring chain length without having the suspension compressed. 2 chain links extra at full compression ends up being almost 5 chain links extra at static height.

    Now that I've got proper chain length it's quiet as a mouse and has amazing shifting.

    -Tom
  • 11-09-2012
    B-Mac
    FWIW, I'm running a X9 type II, running for just over a month & have zero noise or issues. Running a mid cage with a 36t cog, no problems.

    Actually, found this thread b/c I was going to start a thread about how great I thought the Type II is . . . I personally really, really like this RD!! Shifting is extremely smooth & the difference in noise is just profound. The only way I can get noise out of the chain is when you hit a bunch of stutter bumps or decent-sized roots at speed. Jumps, drops, etc are all silent. I will note that I've dropped the chain off the middle ring (I have a 2/10 setup) several times, so the Type II does not seem to work as advertised in that respect. The button that locks the cage forward for wheel changes needs to be on every RD made. Great idea.

    As to b-screw setup, I use the following, extremely scientific & mechanically sound adjustment method: tweak the cage really close to the cogs & adjust it outward slowly until it no longer hangs up during shifts to bigger cogs.

    As some others have mentioned, I added a link to my chain & it seems a bit happier. The link was added due to a trail repair to a broken chain, not because of any problem I was having. The broken chain was my own fault, as I had to add a link to the chain after I cut it b/c forgot that I went from a 34 big cog to a 36, which weakens the rivet on the added link. I didn't have a replacement rivet, so just re-used the one I knocked out.

    YMMV, but my experience has been very positive.
  • 11-09-2012
    in the trees
    I've read that maybe a Medium cage is better for 36T rear cog. Can anyone comment? Still waiting to see how things pan out with this derailleur.

    And will it be released in SRAM's other X.9 colors - red and white?
  • 11-27-2012
    yoeddy20000
    No more issues - went to long cage.
    I was having the clicking issues with a medium cage xo type 2 on a carbon tallboy with a 2x10 (11-36) setup. I switched to the XO long cage and have the chain length exactly as prescribed by SRAM (measure it in big/big OUT OF REAR DERAILLER, with suspension - if applicable fully compressed, then add one link AND the powerlink).

    With that, my clicking is gone and shifting is nice.

    Good luck!
  • 11-29-2012
    Ilikemtb999
    Quote:

    Originally Posted by trhoppe View Post
    My knocking/creaking issues were because the chain was too short. It seems that these derailleurs are more sensitive to a shorter chain. My bike (Trek Remedy) has lots of chain growth and I was measuring chain length without having the suspension compressed. 2 chain links extra at full compression ends up being almost 5 chain links extra at static height.

    Now that I've got proper chain length it's quiet as a mouse and has amazing shifting.

    -Tom

    Same here. My x9 type 2 was knocking on my spider 29 and adding a set of links cured the knock issue. It seems the derailleur just doesn't like the cage that far forward in the stroke.
  • 12-06-2012
    neilether
    Nothing I did could remedy the issue I was having. To their credit SRAM sent a new derailleur to me and threw in a brand new, upgraded chain to boot. I love good customer service.
  • 12-06-2012
    Ilikemtb999
    Nice!
  • 12-06-2012
    jazzanova
    Quote:

    Originally Posted by in the trees View Post
    I've read that maybe a Medium cage is better for 36T rear cog. Can anyone comment? Still waiting to see how things pan out with this derailleur.

    And will it be released in SRAM's other X.9 colors - red and white?

    I run a small xo type 2 cage woth 11-36 1x10 setup. No problems. Though it might be harder to adjust it properly.
  • 12-06-2012
    chtorres2
    3 Attachment(s)
    Its not a chain growth issue
    I just installed a new x9 type 2 short cage and no matter what gear i put the cassete in when I push down on the suspension it makes thee clunking sound. If I put my hand on the clutch part of the deraileur I can feel it. I ride a 1X10 and putting it in the 11T in the casset were it has the most slack of chain you can still hear the clunk. It comes down to good ideas with piss poor planning and production :madman:

    Ive included pics of how the deraileur looks like in the 11T and in the 36T of the rear cassette. Youll notice that its not a chain slack issue when its in the 11T.
  • 12-12-2012
    trailbrain
    Quote:

    Originally Posted by chtorres2 View Post
    I just installed a new x9 type 2 short cage and no matter what gear i put the cassete in when I push down on the suspension it makes thee clunking sound. If I put my hand on the clutch part of the deraileur I can feel it. I ride a 1X10 and putting it in the 11T in the casset were it has the most slack of chain you can still hear the clunk. It comes down to good ideas with piss poor planning and production :madman:

    Ive included pics of how the deraileur looks like in the 11T and in the 36T of the rear cassette. Youll notice that its not a chain slack issue when its in the 11T.

    I'm running a 2x10 and having the exact same issue. I can take the chain off and rotate the cage which will then bind and release creating a knocking noise. When I first noticed the knocking it thought it was the pivots on my brand new bike. The X9 type 2 is the issue.

    SRAM is supposed to warranty so I'll see if the new one does this as well.
  • 12-13-2012
    HillDancer
    3 Attachment(s)
    Quote:

    Originally Posted by neilether View Post
    ...SRAM sent a new derailleur to me and threw in a brand new, upgraded chain to boot. I love good customer service.

    Do you mean that figuratively as in to a bike shop on your behalf, or do you work at a shop, or did they send it to you direct? I've had three email exchanges with SRAM USA, and each reply states "We don't do anything consumer direct.".

    My issue is the chain jumps the lower pulley when shifting from the big ring to small ring, at light load and low rpm. I've seen mention in the MTBR XX derailleur review of some XX owners having this issue, but no other reports like this with Type2 derailleurs.
  • 12-13-2012
    shibiwan
    Been riding my 2+ month old X0 type2 almost daily (8-12 miles of mountain trail + road to / from home) and still working smoothly.

    I do all my own wrenching / installed so if anything breaks it's all my own fault (LOL) . The key in the Type2 adjustment is probably the B pivot adjustment. Had to muck around with it to make it clear the chainstay pivot and still shift cleanly.

    Haven't done much maintenance on the derailleur either.... just ride ride ride and then clean / dust weekly, as and when I'm bored...

    -S

    Sent from my Kindle Fire using Tapatalk 2
  • 01-07-2013
    max_lombardy
    Just curious about what year model the problem derailleurs are... You can tell by looking at the joint where the cage meets the der. body. The 2012's have a big Torx star nut there, and the 2013's have a smooth cap in its place. I would love to hear from those of you who are having this problem... I have a little time on my 2013 XO type 2 and no problems yet. I want to buy one for my other bike but if the 2013's are still problematic I'll just go with a shadow+ XTR. THANKS!!!!!
  • 01-07-2013
    belcourt
    sram type 2
    Quote:

    Originally Posted by testtech View Post
    My medium cage XO type 2 is now working flawlessly on 11-36. The original problems were the result of an installation error by the bike shop mechanic. All I got from this experience was that I will use a different bike shop;

    That's great news as I am having exactly the same problem. What was the installation error? How did you fix it?

    Thanks!

    ****whoops, never mind as the answer was earlier in the thread and I just missed it
  • 01-08-2013
    neilether
    Quote:

    Originally Posted by HillDancer View Post
    Do you mean that figuratively as in to a bike shop on your behalf, or do you work at a shop, or did they send it to you direct? I've had three email exchanges with SRAM USA, and each reply states "We don't do anything consumer direct.".

    Figuratively. My bike shop called it in and got the warranty replacement parts on my behalf.
  • 01-17-2013
    max_lombardy
    Well, I went ahead and got another XO type 2 for my second bike. Now running:
    2x10 with Medium cage XO on my Yeti ASR 5
    1X9 with short cage on my TI hardtail.

    I started to hear the "knock" today on the ASR 5. By fiddling around, I figured out that the sound is just related to the initial overcoming of the friction of the clutch. If you just push down on the lower half of the chain loop you will hear the click. You can also hear it if you listen carefully when you shift. I think it could just be part of the breaking -in process, I'll update again after more hours
  • 01-18-2013
    L. Ron Hoover
    I just installed an X9 type 2 RD on my bike. Running 1x10 (32t up front and 12-36 in the back). It took a bit longer than normal to get it set up but not too bad. I only have one ride in on it but I'm supremely impressed with the noise reduction. I didn't realize just how noisy my chain was until this morning. The lock feature is amazing too. Makes getting the wheel on and off and removing the chain infinitely easier. Hopefully it keeps working like it did this morning. I'll follow up when I get some more rides in on it.
  • 01-27-2013
    Sasquatch29
    I have an medium cage on a 11-36 cassette with a 22-36 crank on a Yeti SB95, it's a tight fit but it works. Variables not foreseen by Sram include RD hanger geometry and chain length growth. Sram's chain length instructions are not very useful. If you expect to bomb all day in the small-small or large-large combination, then definitely follow Sram's compatibility chart. In my case, Yeti tempered the RD hanger to be a sacrificial lamb to avoid bending the frame. My LBS reports the QR pinner skewer RD hangar can bend under the clutch load. I have the 12x142 chip with larger RD hangar, but I still want to keep the medium cage to reduce the loads on the RD hangar. I think if you don't verify the chain isn't too short, you can generate enough loads during suspension compression to damage the clutch resulting in noisy/notchy clutch action. Here is my set up:
    sasquatch29er.blogspot.com
  • 02-18-2013
    ocguy2004
    3 rides on my mid cage type 2 and i'm not a fan. much better ride with my old type 1. didn't account for its super sensitivity to chain growth and the cage would lock on me during rides when the rear shock compressed. plus it gets very difficult to shift at times. hoping my LBS will exchange it for a type one and make me a happy rider again. i'd say avoid this thing til sram can get it right.
  • 03-02-2013
    chopstickslee
    noticed this too on my brand new mech

    pretty disappointed considering the $$ i spent on this mech

    has the knock decreased with use for those who have been using this for a while?
  • 03-02-2013
    defenestratingchupacabra1
    Have been riding my type 2 for nearly six months and no problems at all, I love this thing.
  • 03-02-2013
    ocguy2004
    Quote:

    Originally Posted by chopstickslee View Post
    noticed this too on my brand new mech

    pretty disappointed considering the $$ i spent on this mech

    has the knock decreased with use for those who have been using this for a while?

    I think it might have with mine...either that or I've gotten used to it. I put on a new ,longer chain and took off my chain guide. wasn't happy with the shifting last week. my plan is to beat the crap out of it and go back to using the type 1. if they no longer offer the x9 in type 1 I will drop to x7.
  • 03-07-2013
    Tjay
    I have mid cage x9 type 2 on my superlight 1x10 setup, no chainguide just chain keeper (Paul's). I found out about this thread after I purchased the x9 but still went ahead and used the RD. From day one, I have been hearing this very slight clicking noise BUT only when I pedal off the saddle on harder gear. I will have to double check if it's even the RD. I'll give an update on this. Fyi... This RD came from my hardtail and I didn't have the clicking noise on that bike.

    I recently picked up a short cage X9 type 2 for my Stumpy Evo FSR. I released the air on the rear shock and kept the chain at 32T Front/36T rear (also 1x10 setup) then compressed the shock. Absolutely no clicking noise or whatsoever. I'll have to see how it goes on the trail.