Page 2 of 6 FirstFirst 1 2 3 4 5 6 LastLast
Results 26 to 50 of 126
  1. #26
    mtbr member
    Reputation: neilether's Avatar
    Join Date
    Sep 2007
    Posts
    277
    Quote Originally Posted by testtech View Post
    My medium cage XO type 2 is now working flawlessly on 11-36. The original problems were the result of an installation error by the bike shop mechanic. All I got from this experience was that I will use a different bike shop;
    My new x9 type 2 derailleur began knocking badly today. It ran really nicely for maybe 6-7 rides. Anyway, can you elaborate as to how it was installed incorrectly?

  2. #27
    mtbr member
    Reputation:
    Join Date
    Mar 2009
    Posts
    8
    Im getting clicking noise as well from my type 2 do rear dérailleur, comes from the roller cam area. Derailleur works well, just makes noise.

  3. #28
    mtbr member
    Reputation:
    Join Date
    Sep 2008
    Posts
    784
    My knocking/creaking issues were because the chain was too short. It seems that these derailleurs are more sensitive to a shorter chain. My bike (Trek Remedy) has lots of chain growth and I was measuring chain length without having the suspension compressed. 2 chain links extra at full compression ends up being almost 5 chain links extra at static height.

    Now that I've got proper chain length it's quiet as a mouse and has amazing shifting.

    -Tom

  4. #29
    mtbr member
    Reputation: B-Mac's Avatar
    Join Date
    Oct 2008
    Posts
    751
    FWIW, I'm running a X9 type II, running for just over a month & have zero noise or issues. Running a mid cage with a 36t cog, no problems.

    Actually, found this thread b/c I was going to start a thread about how great I thought the Type II is . . . I personally really, really like this RD!! Shifting is extremely smooth & the difference in noise is just profound. The only way I can get noise out of the chain is when you hit a bunch of stutter bumps or decent-sized roots at speed. Jumps, drops, etc are all silent. I will note that I've dropped the chain off the middle ring (I have a 2/10 setup) several times, so the Type II does not seem to work as advertised in that respect. The button that locks the cage forward for wheel changes needs to be on every RD made. Great idea.

    As to b-screw setup, I use the following, extremely scientific & mechanically sound adjustment method: tweak the cage really close to the cogs & adjust it outward slowly until it no longer hangs up during shifts to bigger cogs.

    As some others have mentioned, I added a link to my chain & it seems a bit happier. The link was added due to a trail repair to a broken chain, not because of any problem I was having. The broken chain was my own fault, as I had to add a link to the chain after I cut it b/c forgot that I went from a 34 big cog to a 36, which weakens the rivet on the added link. I didn't have a replacement rivet, so just re-used the one I knocked out.

    YMMV, but my experience has been very positive.
    Check out my You Tube Channel

  5. #30
    mtbr member
    Reputation: in the trees's Avatar
    Join Date
    Mar 2005
    Posts
    1,825
    I've read that maybe a Medium cage is better for 36T rear cog. Can anyone comment? Still waiting to see how things pan out with this derailleur.

    And will it be released in SRAM's other X.9 colors - red and white?

  6. #31
    mtbr member
    Reputation:
    Join Date
    Mar 2009
    Posts
    8

    No more issues - went to long cage.

    I was having the clicking issues with a medium cage xo type 2 on a carbon tallboy with a 2x10 (11-36) setup. I switched to the XO long cage and have the chain length exactly as prescribed by SRAM (measure it in big/big OUT OF REAR DERAILLER, with suspension - if applicable fully compressed, then add one link AND the powerlink).

    With that, my clicking is gone and shifting is nice.

    Good luck!

  7. #32
    I <3 dirt
    Reputation: Ilikemtb999's Avatar
    Join Date
    Oct 2010
    Posts
    1,350
    Quote Originally Posted by trhoppe View Post
    My knocking/creaking issues were because the chain was too short. It seems that these derailleurs are more sensitive to a shorter chain. My bike (Trek Remedy) has lots of chain growth and I was measuring chain length without having the suspension compressed. 2 chain links extra at full compression ends up being almost 5 chain links extra at static height.

    Now that I've got proper chain length it's quiet as a mouse and has amazing shifting.

    -Tom
    Same here. My x9 type 2 was knocking on my spider 29 and adding a set of links cured the knock issue. It seems the derailleur just doesn't like the cage that far forward in the stroke.
    WHY ARE YOU YELLING??!1

  8. #33
    mtbr member
    Reputation: neilether's Avatar
    Join Date
    Sep 2007
    Posts
    277
    Nothing I did could remedy the issue I was having. To their credit SRAM sent a new derailleur to me and threw in a brand new, upgraded chain to boot. I love good customer service.

  9. #34
    I <3 dirt
    Reputation: Ilikemtb999's Avatar
    Join Date
    Oct 2010
    Posts
    1,350
    Nice!
    WHY ARE YOU YELLING??!1

  10. #35
    mtbr member
    Reputation: jazzanova's Avatar
    Join Date
    Jun 2008
    Posts
    1,406
    Quote Originally Posted by in the trees View Post
    I've read that maybe a Medium cage is better for 36T rear cog. Can anyone comment? Still waiting to see how things pan out with this derailleur.

    And will it be released in SRAM's other X.9 colors - red and white?
    I run a small xo type 2 cage woth 11-36 1x10 setup. No problems. Though it might be harder to adjust it properly.

  11. #36
    Boriqua Puneta
    Reputation: chtorres2's Avatar
    Join Date
    May 2010
    Posts
    178

    Its not a chain growth issue

    I just installed a new x9 type 2 short cage and no matter what gear i put the cassete in when I push down on the suspension it makes thee clunking sound. If I put my hand on the clutch part of the deraileur I can feel it. I ride a 1X10 and putting it in the 11T in the casset were it has the most slack of chain you can still hear the clunk. It comes down to good ideas with piss poor planning and production

    Ive included pics of how the deraileur looks like in the 11T and in the 36T of the rear cassette. Youll notice that its not a chain slack issue when its in the 11T.
    Attached Thumbnails Attached Thumbnails SRAM type 2 derailleur issues-pc060236.jpg  

    SRAM type 2 derailleur issues-pc060237.jpg  

    SRAM type 2 derailleur issues-pc060238.jpg  

    Last edited by chtorres2; 12-06-2012 at 10:03 PM. Reason: Pics
    Only type of shuttle I ride....the ambulance!

  12. #37
    mtbr member
    Reputation:
    Join Date
    Feb 2005
    Posts
    1,187
    Quote Originally Posted by chtorres2 View Post
    I just installed a new x9 type 2 short cage and no matter what gear i put the cassete in when I push down on the suspension it makes thee clunking sound. If I put my hand on the clutch part of the deraileur I can feel it. I ride a 1X10 and putting it in the 11T in the casset were it has the most slack of chain you can still hear the clunk. It comes down to good ideas with piss poor planning and production

    Ive included pics of how the deraileur looks like in the 11T and in the 36T of the rear cassette. Youll notice that its not a chain slack issue when its in the 11T.
    I'm running a 2x10 and having the exact same issue. I can take the chain off and rotate the cage which will then bind and release creating a knocking noise. When I first noticed the knocking it thought it was the pivots on my brand new bike. The X9 type 2 is the issue.

    SRAM is supposed to warranty so I'll see if the new one does this as well.

  13. #38
    mtbr member
    Reputation:
    Join Date
    Dec 2012
    Posts
    55
    Quote Originally Posted by neilether View Post
    ...SRAM sent a new derailleur to me and threw in a brand new, upgraded chain to boot. I love good customer service.
    Do you mean that figuratively as in to a bike shop on your behalf, or do you work at a shop, or did they send it to you direct? I've had three email exchanges with SRAM USA, and each reply states "We don't do anything consumer direct.".

    My issue is the chain jumps the lower pulley when shifting from the big ring to small ring, at light load and low rpm. I've seen mention in the MTBR XX derailleur review of some XX owners having this issue, but no other reports like this with Type2 derailleurs.
    Attached Thumbnails Attached Thumbnails SRAM type 2 derailleur issues-p1020107.jpg  

    SRAM type 2 derailleur issues-p1020110.jpg  

    SRAM type 2 derailleur issues-p1020112.jpg  


  14. #39
    banned
    Reputation:
    Join Date
    Sep 2012
    Posts
    1,510
    Been riding my 2+ month old X0 type2 almost daily (8-12 miles of mountain trail + road to / from home) and still working smoothly.

    I do all my own wrenching / installed so if anything breaks it's all my own fault (LOL) . The key in the Type2 adjustment is probably the B pivot adjustment. Had to muck around with it to make it clear the chainstay pivot and still shift cleanly.

    Haven't done much maintenance on the derailleur either.... just ride ride ride and then clean / dust weekly, as and when I'm bored...

    -S

    Sent from my Kindle Fire using Tapatalk 2

  15. #40
    mtbr member
    Reputation:
    Join Date
    Apr 2012
    Posts
    197
    Just curious about what year model the problem derailleurs are... You can tell by looking at the joint where the cage meets the der. body. The 2012's have a big Torx star nut there, and the 2013's have a smooth cap in its place. I would love to hear from those of you who are having this problem... I have a little time on my 2013 XO type 2 and no problems yet. I want to buy one for my other bike but if the 2013's are still problematic I'll just go with a shadow+ XTR. THANKS!!!!!

  16. #41
    mtbr member
    Reputation:
    Join Date
    Aug 2011
    Posts
    2

    sram type 2

    Quote Originally Posted by testtech View Post
    My medium cage XO type 2 is now working flawlessly on 11-36. The original problems were the result of an installation error by the bike shop mechanic. All I got from this experience was that I will use a different bike shop;
    That's great news as I am having exactly the same problem. What was the installation error? How did you fix it?

    Thanks!

    ****whoops, never mind as the answer was earlier in the thread and I just missed it
    Last edited by belcourt; 01-08-2013 at 08:46 PM. Reason: found my answer earlier in the thread

  17. #42
    mtbr member
    Reputation: neilether's Avatar
    Join Date
    Sep 2007
    Posts
    277
    Quote Originally Posted by HillDancer View Post
    Do you mean that figuratively as in to a bike shop on your behalf, or do you work at a shop, or did they send it to you direct? I've had three email exchanges with SRAM USA, and each reply states "We don't do anything consumer direct.".
    Figuratively. My bike shop called it in and got the warranty replacement parts on my behalf.

  18. #43
    mtbr member
    Reputation:
    Join Date
    Apr 2012
    Posts
    197
    Well, I went ahead and got another XO type 2 for my second bike. Now running:
    2x10 with Medium cage XO on my Yeti ASR 5
    1X9 with short cage on my TI hardtail.

    I started to hear the "knock" today on the ASR 5. By fiddling around, I figured out that the sound is just related to the initial overcoming of the friction of the clutch. If you just push down on the lower half of the chain loop you will hear the click. You can also hear it if you listen carefully when you shift. I think it could just be part of the breaking -in process, I'll update again after more hours
    Last edited by max_lombardy; 01-26-2013 at 12:27 AM.

  19. #44
    mtbr member
    Reputation:
    Join Date
    Feb 2006
    Posts
    591
    I just installed an X9 type 2 RD on my bike. Running 1x10 (32t up front and 12-36 in the back). It took a bit longer than normal to get it set up but not too bad. I only have one ride in on it but I'm supremely impressed with the noise reduction. I didn't realize just how noisy my chain was until this morning. The lock feature is amazing too. Makes getting the wheel on and off and removing the chain infinitely easier. Hopefully it keeps working like it did this morning. I'll follow up when I get some more rides in on it.

  20. #45
    mtbr member
    Reputation: Sasquatch29's Avatar
    Join Date
    Jan 2013
    Posts
    33
    I have an medium cage on a 11-36 cassette with a 22-36 crank on a Yeti SB95, it's a tight fit but it works. Variables not foreseen by Sram include RD hanger geometry and chain length growth. Sram's chain length instructions are not very useful. If you expect to bomb all day in the small-small or large-large combination, then definitely follow Sram's compatibility chart. In my case, Yeti tempered the RD hanger to be a sacrificial lamb to avoid bending the frame. My LBS reports the QR pinner skewer RD hangar can bend under the clutch load. I have the 12x142 chip with larger RD hangar, but I still want to keep the medium cage to reduce the loads on the RD hangar. I think if you don't verify the chain isn't too short, you can generate enough loads during suspension compression to damage the clutch resulting in noisy/notchy clutch action. Here is my set up:
    sasquatch29er.blogspot.com

  21. #46
    mtbr member
    Reputation: ocguy2004's Avatar
    Join Date
    Jul 2006
    Posts
    273
    3 rides on my mid cage type 2 and i'm not a fan. much better ride with my old type 1. didn't account for its super sensitivity to chain growth and the cage would lock on me during rides when the rear shock compressed. plus it gets very difficult to shift at times. hoping my LBS will exchange it for a type one and make me a happy rider again. i'd say avoid this thing til sram can get it right.

  22. #47
    mtbr member
    Reputation:
    Join Date
    Feb 2012
    Posts
    15
    noticed this too on my brand new mech

    pretty disappointed considering the $$ i spent on this mech

    has the knock decreased with use for those who have been using this for a while?

  23. #48
    mtbr member
    Reputation:
    Join Date
    Jul 2010
    Posts
    23
    Have been riding my type 2 for nearly six months and no problems at all, I love this thing.

  24. #49
    mtbr member
    Reputation: ocguy2004's Avatar
    Join Date
    Jul 2006
    Posts
    273
    Quote Originally Posted by chopstickslee View Post
    noticed this too on my brand new mech

    pretty disappointed considering the $$ i spent on this mech

    has the knock decreased with use for those who have been using this for a while?
    I think it might have with mine...either that or I've gotten used to it. I put on a new ,longer chain and took off my chain guide. wasn't happy with the shifting last week. my plan is to beat the crap out of it and go back to using the type 1. if they no longer offer the x9 in type 1 I will drop to x7.

  25. #50
    just ride
    Reputation:
    Join Date
    Oct 2006
    Posts
    629
    I have mid cage x9 type 2 on my superlight 1x10 setup, no chainguide just chain keeper (Paul's). I found out about this thread after I purchased the x9 but still went ahead and used the RD. From day one, I have been hearing this very slight clicking noise BUT only when I pedal off the saddle on harder gear. I will have to double check if it's even the RD. I'll give an update on this. Fyi... This RD came from my hardtail and I didn't have the clicking noise on that bike.

    I recently picked up a short cage X9 type 2 for my Stumpy Evo FSR. I released the air on the rear shock and kept the chain at 32T Front/36T rear (also 1x10 setup) then compressed the shock. Absolutely no clicking noise or whatsoever. I'll have to see how it goes on the trail.

Page 2 of 6 FirstFirst 1 2 3 4 5 6 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •