Results 1 to 8 of 8
  1. #1
    mtbr member
    Reputation:
    Join Date
    May 2009
    Posts
    25

    Shimano STX RC Shifter adjustment

    I'm using a Shimano STX RC rapidfire shifter and a Shimano STX Front derailleurs

    I have 3 chainrings and 8 in back.

    My problem is that I can't seem to get the front derailleurs to work. As a matter of fact it has never worked since I've had the bike. When I say work I mean without the chain rubbing. So I can either have the chain rub when I have the chain on Big Front and Small Back gear, or I can set it so the chain rubs when I have Small front gear, Big back gear.

    I think the problem come in that my rapidfire shifter doesn't give enough cable to the front derailleurs to allow it to travel the distance needed to allow the chain not to rub in either the first or third chainring.

    My Question:

    Is there a way to adjust the rapidfire shifter to give a little more cable on each shift so the front derailleurs aligns properly? Or am I doing something else wrong here?

  2. #2
    ups and downs
    Reputation: rockyuphill's Avatar
    Join Date
    Nov 2004
    Posts
    14,004
    Make sure the front derailleur is parallel with the chainrings. Make sure the high and low limit screws are set properly on the derailleur, that determines where it sits in 1 and 3. The barrel adjuster determines the middle ring trim. Park has a good tutorial.

    http://www.parktool.com/repair/readhowto.asp?id=75
    I'm a member of NSMBA and IMBA Canada

  3. #3
    mtbr member
    Reputation:
    Join Date
    May 2009
    Posts
    25
    Yes, I was using the Park Tool instructions when I was working on my bike. I still have the same problem. The H and L screws are are opened to allow unlimited travel. The rapidfire shifter is just not letting enough cable out between the outer and inner chainrings.

    I need to figure out if there is a way to get the shifter to let out more cable, or if I might have an incompatible setup.

    Does that make sense?

  4. #4
    mtbr member
    Reputation:
    Join Date
    Feb 2008
    Posts
    4,014
    The STX RCs are 7speed or 8 speed?
    roccowt.
    rocnbikemeld

  5. #5
    mtbr member
    Reputation:
    Join Date
    Feb 2008
    Posts
    4,014
    Just guessing...maybe you need to change you bottom bracket to a different spindle length or try to put some type of spacer/washer between the bottom bracket and the bottom bracket shell on the drive (crank) side.
    roccowt.
    rocnbikemeld

  6. #6
    ups and downs
    Reputation: rockyuphill's Avatar
    Join Date
    Nov 2004
    Posts
    14,004
    The cable pull is fixed in the front shifter, so what you might need to do is replace the cable in the shifter, there may be a problem with the way the current cable is seated in the shifter.

    Also make sure the cable is routed under the cable clamp bolt correctly on the derailleur, if it runs on the wrong side of the bolt it might change the leverage ratio (that can happen on the rear derailleur).
    I'm a member of NSMBA and IMBA Canada

  7. #7
    mtbr member
    Reputation:
    Join Date
    May 2009
    Posts
    25
    Quote Originally Posted by zarr
    The STX RCs are 7speed or 8 speed?
    8 speed

  8. #8
    mtbr member
    Reputation:
    Join Date
    May 2009
    Posts
    25
    Quote Originally Posted by rockyuphill
    The cable pull is fixed in the front shifter, so what you might need to do is replace the cable in the shifter, there may be a problem with the way the current cable is seated in the shifter.

    Also make sure the cable is routed under the cable clamp bolt correctly on the derailleur, if it runs on the wrong side of the bolt it might change the leverage ratio (that can happen on the rear derailleur).
    I checked the clamp bolt. The cable is on the correct side. I didn't check the cables in the shifter, this doesn't seem to be the problem anyway, cable comes out and goes in nice and ease, and since there is no way to adjust the cable the shifter gives or takes, I guessing it is working fine.

    For right now I have it working pretty good, with some minor rubbing when in middle or most inner chain ring while also having the chain on one of the most inner 2 or 3 gears.

    I haven't looked yet, but maybe if the cage bolts together I could find a way to make it a half millimeter wider or so using washers.

    Maybe I'll put a front derailleur on my upgrade list also.

    Thanks for the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •