Results 1 to 7 of 7
  1. #1
    mtbr member
    Reputation:
    Join Date
    Apr 2007
    Posts
    3

    Rapidfire shift lever question

    The rapidfire shifter for my Shimano STX front deraileur is not functioing properly. I adjusted the cable tension on the derailier, it's fine. I can shift freely between the little and middle rings, but I cannot get it to shift into the big ring. I push the lever forward, but no "click" and no shift. I know I need to take the shift lever apart. Any ideas of what to look for/what brakes? Thanks.
    -Matt

  2. #2
    mtbr member
    Reputation: Wombat's Avatar
    Join Date
    Jan 2004
    Posts
    1,803
    First make sure it isn't your derailleur or cable. Try pushing the derailleur by hand to see if it will move the chain to the big ring. If it doesn't then something other than your shifter is causing the problem.

    Tim

  3. #3
    mtbr member
    Reputation:
    Join Date
    Apr 2007
    Posts
    3
    I can push the derailer to the big ring and also pull on the cable to shift it without problems. I've narrowed it down to the shift lever.

  4. #4
    Vaginatarian
    Reputation:
    Join Date
    Oct 2005
    Posts
    5,686
    dont know about that model but I once opened a xt shifter. it blew apart. First try to open the cable port and squirt some chain lube inside, if that doesnt work just buy a new one

  5. #5
    mtbr member
    Reputation:
    Join Date
    May 2006
    Posts
    11,198
    I squirt in some WD-40 in the hole to get the cable out, wait about 20 secs, then blow it all out with compressed air.

    Works good when mine freeze up in the winter.

  6. #6
    mtbr member
    Reputation: oldskoolbiker's Avatar
    Join Date
    Jun 2005
    Posts
    1,600
    I have found that the shifters are not really serviceable. Try what jeff suggested, if that doesn't work, here you go:
    http://www.universalcycles.com/shopp...s.php?id=11141

  7. #7
    mtbr member
    Reputation:
    Join Date
    Apr 2007
    Posts
    3
    Quote Originally Posted by oldskoolbiker
    I have found that the shifters are not really serviceable. Try what jeff suggested, if that doesn't work, here you go:
    http://www.universalcycles.com/shopp...s.php?id=11141

    Cool, I'll try what Jeff suggested first, and if not, I'll just buy another one. I never bothered to look, and that seems pretty reasonable anyway. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •