Results 1 to 4 of 4
  1. #1
    mtbr member
    Reputation:
    Join Date
    Oct 2005
    Posts
    13

    Loose chain problem.

    I'm trying to convert my ss inbred to a 1x9 set up, I've got a 22t chainring, gaurd and jumpstop up front, no problems with loosing the chain, which I was expecting. At the back I've got a Deore mech with rollermijig hg70 cassette on a planet x monolith hub, cassette and mech are second hand. The problem is when I freewheel/backpedal the chain goes slack at the top, I've tried a different wheel and it didn't happen, but it was a 7 speed wheel and when I tried to ride it the chain skipped. Any ideas welcome, is it the freewheel or cassette? something else? I don't mind buying a new cassette but I don't want to waste money if it could be something else. It happens in all cogs. Thanks Richard.

  2. #2
    Nouveau Retrogrouch SuperModerator
    Reputation: shiggy's Avatar
    Join Date
    Dec 1998
    Posts
    48,134
    Sounds like a bum freehub body.
    mtbtires.com
    The trouble with common sense is it is no longer common

  3. #3
    mtbr member
    Reputation:
    Join Date
    Oct 2005
    Posts
    13
    Cheers for the reply but what do you mean by freehub body? is it servicible? I'm new to all this so do I need a new wheel/hub or can the lbs sort it out?

  4. #4
    Nouveau Retrogrouch SuperModerator
    Reputation: shiggy's Avatar
    Join Date
    Dec 1998
    Posts
    48,134
    mtbtires.com
    The trouble with common sense is it is no longer common

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •