Results 1 to 2 of 2
  1. #1
    mtbr member
    Reputation:
    Join Date
    Oct 2006
    Posts
    38

    New question here. cane creek terros cassette installation problems

    Hey Everone, not sure if this is the right forum but I figured I'd pose this to you all anyway.

    I recently purchased a canecreek terros wheelset. When installing the cassette, (sram 9speed) as I tighten the lockring the cassette gets progressively harder to turn. I have ensured the cassette is assembled and installed on the hub correctly.

    I am not getting anywhere near 40 nm torque and I as I continue to tighten the lockring, the cassette eventually ceases to turn. It seems to be putting sideload on the hub bearings. Do these hubs require less torque? This cassette is used (maybe 100 miles) but worked perfectly on a DT swiss hub. What am I doing wrong?

    Thanks in advance,

    Jack

  2. #2
    mtbr member
    Reputation:
    Join Date
    Oct 2006
    Posts
    38

    Smile Ok I figured it out...

    The lockring was bottoming against the seal/bearing. I removed the seal and lightly tapped the bearing into the hub, it apparently wasn't fully seated and the lockring was actually making contact with both of them once it was tightened. Once I reassembled everything, I was able to torque the ring fully and the cassette spins freely like its supposed to. Its a lot quieter than the DT hub, which I thought was pretty quiet itself!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •