Results 1 to 5 of 5
  1. #1
    mtbr member
    Reputation: likeaboss's Avatar
    Join Date
    Jan 2012
    Posts
    633

    Adjustments problems with SRAM x.9 rear der.

    I just swapped out my 2011 x.9 10 sp long cage der for the exact same model with med cage. I also installed a new cable. I have set the B screw so it has 6mm clearance at the largest gear. I have also set the hi and lo limiters. Cable tension is good.

    The problem is that the shifter shifts perfectly gears 1-8. When I click the shifter to go from 8 to 9 it perfectly jumps two gears and lands on 10. At this point there are no more clicks left on the shifter. Shifter is SRAM x.7.

    Shifting from 10 to 9 does the same thing and perfectly skips 9 and lands on 8.

    Any help is appreciated.

  2. #2
    mtbr member
    Reputation:
    Join Date
    Nov 2011
    Posts
    1,799
    I'd say you are one step out - it jumps to the end because the last click depends on the limiting screw.
    Tighten the cable about 1/8 inch and see if it's close.

  3. #3
    mtbr member
    Reputation: likeaboss's Avatar
    Join Date
    Jan 2012
    Posts
    633
    Thanks Slash, that makes sense. I think I tried that but I will give it another go.

  4. #4
    Trail Tire TV on blogger
    Reputation: thomllama's Avatar
    Join Date
    Oct 2007
    Posts
    3,617
    ya... what Stash5 said. guessing when you sat "8-9-10" you mean the smaller gears? you have the cable too loose most likely... probably had the shifter up one when installing the the cable to the derailleur. shift all the way down to the bottom and un do the clamp.. don't try with the barrel as you'll probably end up with it sticking WAY out... (thou it'll probably work, but look goofy )

    Manually pull on the cable while shifting to make sure all the cable is out of the shifter and to make sure it clicks down...

    Also many 10 speed setups use a 10-12 mm adjustment of the B screw... read the manual to check.... too close and you can bend/prematurely wear the cassette teeth.
    Going to try and bring Trail Tire TV back. go take a look... http://trailtiretv.blogspot.com/

  5. #5
    mtbr member
    Reputation: likeaboss's Avatar
    Join Date
    Jan 2012
    Posts
    633
    I tried again tonight and made sure I shifted all the way down. I counted 9 clicks so I knew the shifter was fine. I reconnected the cable and now the der is working perfectly.

    Thanks for all the suggestions.

Similar Threads

  1. SRAM X.9 Problems
    By CS2 in forum Drivetrain - shifters, derailleurs, cranks
    Replies: 22
    Last Post: 04-02-2013, 01:33 PM
  2. Rear Shifter Barrel Adjustments
    By sinfony78 in forum Drivetrain - shifters, derailleurs, cranks
    Replies: 4
    Last Post: 01-15-2013, 01:35 AM
  3. Rear derailleur adjustments for middle gears
    By codyh12345 in forum Drivetrain - shifters, derailleurs, cranks
    Replies: 6
    Last Post: 05-31-2012, 03:07 PM
  4. Replies: 24
    Last Post: 08-01-2011, 01:52 PM
  5. Rear derailleur adjustments
    By Enslaver in forum Drivetrain - shifters, derailleurs, cranks
    Replies: 6
    Last Post: 03-20-2011, 08:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •