Results 1 to 6 of 6
  1. #1
    mtbr member
    Reputation: rollertoaster's Avatar
    Join Date
    Jun 2007
    Posts
    1,133

    Anyone have a Vivid on their F5?

    I'm running a DHX5 w/Ti spring right now. It's [I]OK[I], but certainly not great. I get compression spikes even with low boost pressures. Has anyone tried a Vivid on theirs yet? What do you think?
    Team _________

  2. #2
    mtbr member
    Reputation: theOtherMrT's Avatar
    Join Date
    Jul 2004
    Posts
    117
    yes, it's awesome. The faster you go the better it gets

  3. #3
    Flying Goat
    Reputation: mrpercussive's Avatar
    Join Date
    Apr 2006
    Posts
    11,330
    i've seen a couple people with them on their F5s... cant remember who though...

  4. #4
    mtbr member
    Reputation: rollertoaster's Avatar
    Join Date
    Jun 2007
    Posts
    1,133
    We were set up next to Lars at the US open. He's had one on for about a year and he said he liked it. I just need to get rid of a couple parts before I pull the trigger. It's gonna kill me to not be able to have a Ti spring right away.

    I don't really know what's up with the F5 right now, it was super reliable since I got it, but lately it's broken like every week. I was having issues with the dogbone bolt breaking/bending. I think I've got that straightened out, then my DU bushings in the shock developed play, and when I tried to take the bolt out of the linkage it wouldn't unthread from the nut in the linkage.
    Team _________

  5. #5
    Flying Goat
    Reputation: mrpercussive's Avatar
    Join Date
    Apr 2006
    Posts
    11,330
    Quote Originally Posted by rollertoaster
    We were set up next to Lars at the US open. He's had one on for about a year and he said he liked it. I just need to get rid of a couple parts before I pull the trigger. It's gonna kill me to not be able to have a Ti spring right away.

    I don't really know what's up with the F5 right now, it was super reliable since I got it, but lately it's broken like every week. I was having issues with the dogbone bolt breaking/bending. I think I've got that straightened out, then my DU bushings in the shock developed play, and when I tried to take the bolt out of the linkage it wouldn't unthread from the nut in the linkage.
    sorry to hear about your bad luck on the bike dude... but yea, you know what to do...

    http://www.chumbaracing.com/contact_us.shtml

  6. #6
    mtbr member
    Reputation: rollertoaster's Avatar
    Join Date
    Jun 2007
    Posts
    1,133
    Yeah, I'm just waiting to hear back. I sent an email rather than calling this time just because I wanted to show them pictures of the problems I'm having.
    Team _________

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •