Results 1 to 12 of 12
  1. #1
    ganginwood
    Reputation: ganginwood's Avatar
    Join Date
    Mar 2005
    Posts
    481

    pumping the lefties.....all of them

    is it just on my forks (3 lefties) or on all later models, that the shock pump won't register a preassure. on my latest bike, i can't remove any air with a standard shock pump.
    i also can't get accurate preassure readings on any of my forks. the valve needle is too high into the stem. the shop says they're all coming like that. what gives?

    below is the wifes bike.... just finihsed putting it together. unfortunately i have to use a scott shock pump to register/remove any preassure becuase it has an adjustable adapter on the nozzle. i have to return the pump soon. anyone have something that works?
    Attached Images Attached Images
    Quote Originally Posted by Mike Aswell
    the 5th poster, ganginwoods, is correct

  2. #2
    mtbr member
    Reputation: HAL 9000's Avatar
    Join Date
    Apr 2008
    Posts
    1,581
    Eko Sport Air Tight SV Shock Pump Adapter solved my problem

  3. #3
    Ground Pounder
    Reputation: MrHappyMedium's Avatar
    Join Date
    Feb 2007
    Posts
    304
    The Topeak PocketShock works great for me on my Lefty Speed 110, Float R and Float RP23.
    My bicycle gets more dirt than your 4x4.

  4. #4
    mtbr member
    Reputation:
    Join Date
    Jan 2008
    Posts
    23
    I have the same issue on my 08 Rush 4. My shox doesnt read unless I thread it on really really tight. I tried another pump and it was the same deal.....

  5. #5
    mtbr member
    Reputation: Yuengling's Avatar
    Join Date
    Aug 2006
    Posts
    150
    Quote Originally Posted by XtoZ
    I have the same issue on my 08 Rush 4. My shox doesnt read unless I thread it on really really tight. I tried another pump and it was the same deal.....
    I have the same problem with my 2006 Speed DLR. It has to be TIGHT to get a reading and add/remove air.
    Cannondale Caffeine 2 29er
    Redline Monocog Flight 29er
    Fuji RC Team
    Kona Jake the Snake
    Blk Mrkt Mob

  6. #6
    mtbr member
    Reputation:
    Join Date
    Nov 2007
    Posts
    56
    here are some tips Can't Air up my Lefty

  7. #7
    mtbr member
    Reputation: rumshcawheely's Avatar
    Join Date
    May 2007
    Posts
    361
    This is a problem that has been know for quite some time now and cdale will replace the part at no additional fee. Just take it to you cdale dealer and tell them to call cdale's tech dept. and in a week or two you'll get your replacement valve assembly. It's real simple to change.

  8. #8
    mtbr member
    Reputation:
    Join Date
    Feb 2008
    Posts
    16
    I use a Fox shock pump and have never had a problem in my '07 Lefty Carbon SL 110...just make sure to fit it tight (not ultra tight, just as tight as you would go with any other pump I guess) and it should work fine.

  9. #9
    mtbr member
    Reputation: Tinshield's Avatar
    Join Date
    Jul 2007
    Posts
    2,084
    Why is your wife's bike thrown in the bushes?
    JRA Cycles
    My Trek HiFi
    NEMBA Racing
    SNEMBA
    I love learning new things in my pajamas.

  10. #10
    ganginwood
    Reputation: ganginwood's Avatar
    Join Date
    Mar 2005
    Posts
    481
    Quote Originally Posted by Tinshield
    Why is your wife's bike thrown in the bushes?
    not sure.. need to ask her. its usually me she throws into the bushes.
    Quote Originally Posted by Mike Aswell
    the 5th poster, ganginwoods, is correct

  11. #11
    mtbr member
    Reputation: Tinshield's Avatar
    Join Date
    Jul 2007
    Posts
    2,084
    Quote Originally Posted by ganginwood
    not sure.. need to ask her. its usually me she throws into the bushes.
    Mine throws me under the bus.
    JRA Cycles
    My Trek HiFi
    NEMBA Racing
    SNEMBA
    I love learning new things in my pajamas.

  12. #12
    mtbr member
    Reputation:
    Join Date
    Nov 2007
    Posts
    56
    Quote Originally Posted by andygua
    I use a Fox shock pump and have never had a problem in my '07 Lefty Carbon SL 110...just make sure to fit it tight (not ultra tight, just as tight as you would go with any other pump I guess) and it should work fine.
    Sure, none of us could figure that out, thanks a lot for that advice...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •