Results 1 to 10 of 10
  1. #1
    mtbr member
    Reputation: karlmichael's Avatar
    Join Date
    Mar 2008
    Posts
    253

    Prophet frame sqeaking under heavy load

    When im climbing uphill on my prophet and im really cranking on her i get a sqeak sound from the rear of my bike. I have cleaned the seat tube, seat clamp, spd peddels, bottom bracket and crank, E type bottom bracket front derailler, and put in a new swing arm bearings. any other advice? brakes? cable stops? rear derailler hanger?

    karl

  2. #2
    mtbr member
    Reputation: Duncan1104's Avatar
    Join Date
    Aug 2007
    Posts
    1,170
    I've had the little plastic sleeves for the cable guides cause creaks. Clean them up and give it a try. Could your frame have a crack?

  3. #3
    Just Ride.
    Reputation: Joel.'s Avatar
    Join Date
    Aug 2009
    Posts
    729
    It is either the rear shock bushes or the rear wheel bearings. Mine had both gone.

  4. #4
    mtbr member
    Reputation: 2clue's Avatar
    Join Date
    Jun 2007
    Posts
    1,255
    I've tried about everything to get rid of my squeak.....but still no cigar. It's something i have just gotten use to about my prophet, under heavy/hard mashing uphills its going to creak.

    You could try lubing pretty much everything on the bike that moves or has and other metal to metal contact, Even then I think the squeak still going to be there,

  5. #5
    mtbr member
    Reputation:
    Join Date
    Jul 2006
    Posts
    40
    if your prophet is an older one, 2005, i think they had some defective swingarms that either ticked or creaked, was lots on this site about it back then. Cdale website may also have some tech docs on it. pretty sure it was more of an annoyance than a real problem.

  6. #6
    Ridin' dirty!
    Reputation: cdalemaniac's Avatar
    Join Date
    Jun 2007
    Posts
    1,896
    Quote Originally Posted by kinta
    if your prophet is an older one, 2005, i think they had some defective swingarms that either ticked or creaked, was lots on this site about it back then. Cdale website may also have some tech docs on it. pretty sure it was more of an annoyance than a real problem.
    It wasn't year specific.....ANY Prophet from ANY year can develop this creak.....
    Remove your swing arm, spray some WD40 or better yet chain lube inside the hotbox (where the rd cable enters) and let it sit overnight with the hotbox flat on the ground.....
    This is the "Official" cure and works well.
    You have to really soak it and spray a bunch in there.....just drain the excess the next day.
    "Common sense isn't always that common!"
    Custom Prophet and Custom Delta V

  7. #7
    mtbr member
    Reputation:
    Join Date
    Jul 2006
    Posts
    40
    here is the link to the tech note, it gives a serial.

    http://www.cannondale.com/can/eng/Ca...echnote_en.pdf

  8. #8
    Ridin' dirty!
    Reputation: cdalemaniac's Avatar
    Join Date
    Jun 2007
    Posts
    1,896
    Quote Originally Posted by kinta
    here is the link to the tech note, it gives a serial.

    http://www.cannondale.com/can/eng/Ca...echnote_en.pdf

    Swing arms with later serial numbers are affected too.....if you use the search function you'll see that this was covered here numerous times.....a lot of folks had this problem although the serial number did not match the one mentioned in the tech note.
    The only way to determine whether or not the swing arm itself is squeaking/clicking, is to take it off, clamp it into a vice (as per cannondale tech note) and test it.
    If swing arm is the source of the problem, then the "lubricating procedure" as I mentioned before is the next step.
    If clicking/squeaking persist even after the treatment your local cannondale dealer will ensure a replacement swing arm to the Original Owner only of course.
    "Common sense isn't always that common!"
    Custom Prophet and Custom Delta V

  9. #9
    mtbr member
    Reputation:
    Join Date
    Mar 2004
    Posts
    1,366
    I have a Stumpjumper that's been creaking for 3 years now and my Rush started it last year.I thoroughly inspect the frames and roll with it.

    It used to bother me terribly but now I'm immune to it plus i hate troubleshooting.

  10. #10
    mtbr member
    Reputation: karlmichael's Avatar
    Join Date
    Mar 2008
    Posts
    253

    ill try the lube fix

    i had my rear hope pro 2 hub serviced about 3 months ago. i had broken a spring in side the hub and hope sent out some stronger springs. ill pull the swing arm and ill pull the cables and clean and lube them up.. thanks for the link and the info guys. im getting a 2011 PBR 140 and i want my prophet to be perfect for the first sweet ride



    karl

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •