Results 1 to 8 of 8
  1. #1
    mtbr member
    Reputation:
    Join Date
    Dec 2010
    Posts
    25

    Moto Carbon 2 Clicking sound....need help

    my 2009 Moto Carbon 2 makes a Clicking sound whenever i pedal it hard, when i puch down it clicks, but when i pull up on the pedals while clipped in it doesnt, already checked the bottom brakcet, changed link bearings, replaced clipless pedals. please help me if anyone ever experienced this. thanks

  2. #2
    mtbr member
    Reputation:
    Join Date
    Aug 2010
    Posts
    30
    Quote Originally Posted by intsikko
    my 2009 Moto Carbon 2 makes a Clicking sound whenever i pedal it hard, when i puch down it clicks, but when i pull up on the pedals while clipped in it doesnt, already checked the bottom brakcet, changed link bearings, replaced clipless pedals. please help me if anyone ever experienced this. thanks

    I got a moto 4 and get this clicking as well, have not really thought that much about it since it did it since i bought it.

    I always thought it was from the rear suspension... if it is a problem i would like to know though

  3. #3
    TXTony
    Guest
    Make sure the pivot bolts are tight...

  4. #4
    mtbr member
    Reputation:
    Join Date
    Dec 2007
    Posts
    31
    Try to take out your seatpost, clean it and grease it well before reinstalling it.
    YAARRR!!!

  5. #5
    mtbr member
    Reputation:
    Join Date
    Dec 2010
    Posts
    25
    already checked the seatposts too, all bolts are tight and the links are grased up already. there are times that it doesnt click. its really weird

  6. #6
    mtbr member
    Reputation:
    Join Date
    Oct 2007
    Posts
    517
    I have a Prophet and I had a similar clicking, Cannondale replaced my swingarm at no charge.

  7. #7
    mtbr member
    Reputation: andrewnielson's Avatar
    Join Date
    Jun 2008
    Posts
    617
    check the bottom bracket or the seatpost. if you wash your bike with a hose or a high pressure sprayer than water can get down in your BB from your seatpost and create clicks and creaks with all the grime down there

  8. #8
    mtbr member
    Reputation: Hotel12's Avatar
    Join Date
    Jan 2008
    Posts
    118
    Also worth to try is checking dropout bolts.(those two tiny bolts) My creaking sound disappeared when I tightened them to right torgue.
    My fleet:
    System six 08
    Moto 1 08
    Jekyll 1000(04)
    Perp 3 (08)

    Had R700 (05)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •