Results 1 to 3 of 3
  1. #1
    mtbr member
    Reputation:
    Join Date
    Dec 2008
    Posts
    90

    Lefty Carbon Issue Pumping Air Hard Time

    Hi.
    I have a Lefty Carbon SL OPI from 2009 bought in second hand as new in 2010, and the only issue since then is that when i try to pump air on it it doesnīt let me, or i have to force it a lot. First i tought it was the pump that was malfunctioning but pumping on other suspensions it works great.
    At first visit to the lbs i reported that problem to the mechanic and he said probably it was the lefty valve. He changed it. But it didnīt work.

    Anyone has any insights? The lefty works great tho, but i canīt pump air so easly and never know the pressure iīm riding.
    It went to 3 revision alredy and never resolved this issue
    thanks

  2. #2
    All Lefty's, all the time Moderator
    Reputation: MendonCycleSmith's Avatar
    Join Date
    Feb 2005
    Posts
    12,715
    Some of those valve pins can be kinda deep. Certain pumps won't reach it. Either try a different pump, or, use a small ball bearing in the pump head to act as a actuation pin "extender". Just be careful to only screw on the pump till it registers pressure, as continuing to screw it on could crush the valve....
    This is a Pugs not some carbon wannabee pretzel wagon!!

    - FrostyStruthers



    www.mendoncyclesmith.com

  3. #3
    mtbr member
    Reputation:
    Join Date
    Dec 2008
    Posts
    90
    Thanks mate..iīll try another pump

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •