Results 1 to 5 of 5
  1. #1
    mtbr member
    Reputation:
    Join Date
    May 2006
    Posts
    148

    Anibody had to replace rear swingarm on Rush?

    A few days ago I posted a thread about annoying nice that I could hear in every revolution of pedals. You guys were very helpfull with suggestions, but nothink worked . So I took my bike to a friends shop (he doesnt sell C'dale) to have checked it out. We have checked everything once again (BB, rear cassete, hub, deriuler hanger, cables, seat tube etc..). But all we could do, was to conclude that the noise was coming from rear swingarm when under side load. There was a note on C'dale page about possible problems with swingarms for rush and prophet (it was the swingarms with code that ended with 00, my swingarm has the code that ends with 01, but it has the same problem).
    Has anybody had to change swingarm on their Rush because of this problem?
    Or should I just burn my bike and start running?

  2. #2
    mtbr member
    Reputation:
    Join Date
    Nov 2004
    Posts
    447
    I had a Team Replica Aluminum Rush with the same problem. Mine was quickly replaced by Cannondale and was NOT in the serial number range.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Apr 2007
    Posts
    20
    I had a noise that we couldn't find, and thought we had a bad swingarm. It turned out to be the DU bushings on the shock mount, so maybe you can try lubing them, it worked on mine.
    Billy

  4. #4
    mtbr member
    Reputation:
    Join Date
    May 2006
    Posts
    148
    Well, after lubing all the rear section of the bike the noise was still there (when pedaling hard). Or if I moved swingarm from left to right I could hear that niose too. Two days ago I took bike to a friend of mine that works in bike shop, and he checked out the bike, and lube everything, but the noise was still there.
    Yesterday I went for a ride (like 70 km and 1.300 meters of ascent- so pretty discent ride) and not a sound all the ride?!
    So, Carpecanom I hope You are right, that the dry buhings were the problem. Just in case I'll take it to an authorised C'dale dealer tomorow (can't harm, the bike is still in warranty).

  5. #5
    mtbr member
    Reputation:
    Join Date
    Apr 2007
    Posts
    1
    I have an 06 Rush 3 and I had the same problem. My LBS - Halters lubed, tightened, replaced and adjusted everything possible to no avail. Cannondale replaced the swingarm and all is good.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •