Results 1 to 5 of 5
  1. #1
    mtbr member
    Reputation:
    Join Date
    Mar 2010
    Posts
    9

    Need Help mounting Dia Comp 980 Fr. Brakes

    Hey,

    I have a old Schwinn High Sierra. The front Canti. Brake bosses were missing so I got some and took them to a local weld shop. The guy tack welded them for me so I could make sure everything lined up before final welding.

    My problem is I can't get the return springs to work. It's like something is backwards. I took a picture. Does this look right?......The three small holes are on the inside near the wheel. It seems like they should be on the outside.

    It's almost like the three small spring anchor holes should be on the outside, or reverse of the way they are....Or am I missing something simple?

    Any help is GREATLY appreciated!!

    Scott

    Not sure if this picture is going to upload or not.
    Attached Thumbnails Attached Thumbnails Need Help mounting Dia Comp 980 Fr. Brakes-brian-project.jpg  


  2. #2
    *****************
    Reputation: Bikinfoolferlife's Avatar
    Join Date
    Feb 2004
    Posts
    12,378
    The spring tension holes are in the right orientation. Must be something else.
    "...the people get the government they deserve..."
    suum quique

  3. #3
    mtbr member
    Reputation:
    Join Date
    Jul 2004
    Posts
    1,077
    Try swapping the spring between right/left, or flipping them. You probably have the spring in backward.

  4. #4
    mtbr member
    Reputation:
    Join Date
    Mar 2010
    Posts
    9
    I took the back brakes apart and found out the springs I got with these 980's can't be right. The bent part of the spring that mounts in the retaining hole is 180 degrees opposite of what the back springs are. I've tried them in every orientation. I took the back's apart and put them back together with no problems.

    Anyone have any extra springs......If not I think I'll go to E-bay and try some different brakes.

    Thanks!

  5. #5
    mtbr member
    Reputation:
    Join Date
    Jul 2004
    Posts
    1,077
    You got me dig up my Dia Compe XCE. The spring arm extrudes out of the plastic retainer at the 6 o'clock position (directly at the bottom). So when you mount it, the canti arms are 3 o'clock and 9 o'clock position without cable. That's not how it sits? You know, your local bike shot probably has hundres of these little springs in their RIP drawers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •