• 02-13-2012
    tcapri87
    Is my Avid BBS front brake shot?
    Today on my ride my front brake decided to stop working. It is an Avid BB5. After closer examination I discovered that the brake doesn't go back to its original position after the brake lever is pulled. Can this be fixed? I have no idea. It feels like the spring is broken, but I am not sure if I can fix it or just get another brake.
  • 02-13-2012
    Wombat
    Remove the cable and see if it returns properly. if it does then the cable's the problem.

    Tim
  • 02-14-2012
    lightjunction
    +1. Could just be an issue with a kink in your cable/housing or dirt in your housing. Either could cause excess friction which could prevent your brake arm from returning to it's original position.
  • 02-14-2012
    tcapri87
    there was a kink in my cable, so replaced the cable and wire. Did nothing. I think the brake is done. Didn't return to original position
  • 02-14-2012
    lubes17319
  • 02-14-2012
    bikeman1
    I had the exact same problem, same brake. You have to take apart the caliper fully, and get into the bearings. Clean everything with Alcohol. Polish all moving parts..etc. Place the bearings back in and make sure they are seated correctly in the bearing race - This is the most important part to ensure it doesn't stick. Once you have it seated, install the spring and put the funny looking star bolt back in (finger tight). Install and test. If it still sticks, you need to get the bearings seated properly - keep trying that until it works, took about 3 attempts for me.
  • 02-15-2012
    tcapri87
    Quote:

    Originally Posted by bikeman1 View Post
    I had the exact same problem, same brake. You have to take apart the caliper fully, and get into the bearings. Clean everything with Alcohol. Polish all moving parts..etc. Place the bearings back in and make sure they are seated correctly in the bearing race - This is the most important part to ensure it doesn't stick. Once you have it seated, install the spring and put the funny looking star bolt back in (finger tight). Install and test. If it still sticks, you need to get the bearings seated properly - keep trying that until it works, took about 3 attempts for me.

    Sounds good. Will definitely try that. You are talking about the screw on the circular brake pad adjuster facing the wheel, correct?
  • 02-15-2012
    bikeman1
    The part where it says bb5 - opposite the adjuster side, is a bit of plastic. You need to pull off the bb5 logo (red) with a small flat head. Then you will see a screw which you need to take out. On the adjuster side (closest to wheel) , keep turning it until it pops off - you may need to bend the little red tabs to get it off. Then once you have the spring out, push the bearing race out through the other side.