Results 1 to 4 of 4
  1. #1
    Thread Killer
    Reputation: bucksaw87's Avatar
    Join Date
    Jun 2007
    Posts
    695

    kool-stop feeling mushy

    i got some of the eagle-2 all weather pads and put 'em on my bike. they stop just fine, don't get me wrong; in fact, they're much better than the OEM pads. thing is, they feel very soft. i'll pull the lever to get the bike to stop, which it does, then i'll keep pulling the lever. the brake lever will actually get to the grip...i can only imagine the brake pad is softer, and it's compressing and deforming much more than it should. so, i'm wondering if this is normal at all, or if i just don't have my brakes adjusted enough.

  2. #2
    mtbr member
    Reputation:
    Join Date
    Oct 2006
    Posts
    2,621
    They are soft but that alone shouldn't let the lever go to the bar. I suspect you need to tighten up the cables.

  3. #3
    Meh.
    Reputation: XSL_WiLL's Avatar
    Join Date
    Nov 2004
    Posts
    17,516
    Are you running too much toe on the pads? Is the pad surface nearly parallel to the rim brake surface? Or does part of the pad (top, bottom, front, back) hit the rim before other parts? This sounds like an alignment problem to me.

  4. #4
    Thread Killer
    Reputation: bucksaw87's Avatar
    Join Date
    Jun 2007
    Posts
    695
    they're toed in a little. i did tighten the cable and fiddle with the set-screws though, and that seeems to have helped. now they actually feel a lot firmer than the OEM pads...go figure

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •