Results 1 to 4 of 4
  1. #1
    mtbr member
    Reputation:
    Join Date
    Jul 2011
    Posts
    87

    kcnc v-brake lacking bite

    took my rebuilt adroit out on its maiden voyage and noticed my kcnc rear brake had little to no stopping power. Has anybody else had this problem? , do I need different pads maybe? , any suggestions.

  2. #2
    mtbr member
    Reputation:
    Join Date
    May 2011
    Posts
    238
    Did the pads on the rear get broken in?

    If not, I would guess rim contamination. Do you use spray lubricant on your drivetrain, and maybe accidentally got it on the rim? You can clean the rim with rubbing alcohol to get anything greasy off.

    You also might need to check your pads for contamination. You can search for how to decontaminate pads, but that usually is only applicable for disc brake pads. You can either sand off contaminated layers of the pads, or get new ones.

    Good luck.
    Bamboo is real.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Jul 2011
    Posts
    87
    Everything is new so contamination should'nt be the problem, was wondering if maybe I got a bad set of pads. Will sand the surface before my ride to work this a.m.

  4. #4
    Bicyclochondriac.
    Reputation:
    Join Date
    Jan 2004
    Posts
    13,174
    Quote Originally Posted by norsk biker View Post
    Everything is new so contamination should'nt be the problem, was wondering if maybe I got a bad set of pads. Will sand the surface before my ride to work this a.m.
    Pads might just need to bed in and mate to the rim surface. You might check how they are contacting the rim.

    What kind of pads? Some are much better than others.
    15mm is a second-best solution to a problem that was already solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •