Results 1 to 3 of 3
  1. #1
    mtbr member
    Reputation: farmertan's Avatar
    Join Date
    Oct 2004
    Posts
    659

    Juicy 5 lever return

    My Avid Juicy 5ís that came on my Stumpjumper are about 9 months old. The lever does not return quickly after braking. The brakes donít feel spongy when braking, but right afterwards the lever has a lot of play. It takes about 10-15 seconds for the play in the lever to dissipate. I donít know if the issue is the calipers or the levers. I have Juicy 7ís on my other bike and my wifeís bike has Juicy 5ís; neither has this issue. Iíve tried spraying lube in the lever pivots, but no success. Anyone have this issue or have any advice? Thanks.

  2. #2
    Meh.
    Reputation: XSL_WiLL's Avatar
    Join Date
    Nov 2004
    Posts
    17,516
    Pull everything (lever, knuckle, pushrod) out and clean thoroughly. Sometimes stuff just gets gunked up in there. I had an issue with Loctite getting on everything.

    If that's not the issue... try bleeding it. Otherwise, sounds like it's a MC issue.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Jan 2005
    Posts
    313
    The seal inside the lever (next to the spring) may be damaged, I had that same issue with my Juicy 7 front brake and although I didn't have a replacement seal was able to fix it. The seal was slightly damaged on one end and a small piece of rubber had come off and may have blocked the movement.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •