Results 1 to 3 of 3
  1. #1
    mtbr member
    Reputation: zenkem's Avatar
    Join Date
    Dec 2007
    Posts
    496

    Hyd Brake Chatter

    My Cannondale F4, Tektro Aquila front brake developed a chatter, sort of like when your ABS kicks off in your car. A friend was telling me he had the same problem on a previous bike and it didn't go away until he swapped out his pads.

    The alignment is good and the disc is clean (no oil) with just under 100 miles.

    Just wondering if it's the pads or the hyd. brake system itself???

  2. #2
    mtbr member
    Reputation: Aresab's Avatar
    Join Date
    Mar 2007
    Posts
    1,232
    It does sound like a pad prblem. I bought a few sets of them when Jenson was clearing them out cheap, some I used the stock pads, others I bough eBay pads from "Bikefridge". You may want to clean the rotor, and lightly remove the glaze from the pads with some fine sandpaper. If that does not solve it, try new pads. They are the same as the older Deore M525 pads, so you should have many options.

  3. #3
    mtbr member
    Reputation: zenkem's Avatar
    Join Date
    Dec 2007
    Posts
    496
    I gave everything a once over and aligned the caliper again for today's ride...if it persists I'll try swapping the pads...I may just swap them out anyway just because.

    THX for the input, I wasn't sure 'bout which pads to get!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •