Results 1 to 6 of 6
  1. #1
    mtbr member
    Reputation:
    Join Date
    Aug 2013
    Posts
    9

    Front xt keep rubbing

    Got new xt brakes and the front is giving me problems. Every time I come back from a spin the calliper has moved slightly Causing rubbing. So I loosen the bolts holding the calliper to the frame, pull and hold the front brake and tighten the bolts carefully (half turn each bolt until tight). I feel at this stage I'm tightening the bolts extremely tight and am afraid to tighten them further. Saying that if the calliper is moving after a spin the bolts must not be tight enough.. Very confused by this. I'm afraid I may break something if I tighten them more. Anyone else experience this or no what's up? Thank u

  2. #2
    mtbr member
    Reputation:
    Join Date
    Jun 2011
    Posts
    710

    Re: Front xt keep rubbing

    True your wheel.

    Sent from my HTC EVO LTE

  3. #3
    rebmem rbtm
    Reputation:
    Join Date
    Apr 2007
    Posts
    2,912
    Tightening torque: 6 - 8 Nm {53 - 69 in. lbs.}

  4. #4
    El CicloPath!!!!!!!
    Reputation:
    Join Date
    Nov 2012
    Posts
    248
    You need to reset the brake. Reset the pistons, center the caliper to the disc. Make sure the pistons are moving evenly.

    Or, instead of using the sqeeze brake method, align the disc between the pads by sight, using a flashlight.

  5. #5
    mtbr member
    Reputation:
    Join Date
    Aug 2013
    Posts
    9
    Quote Originally Posted by Fachiro1 View Post
    You need to reset the brake. Reset the pistons, center the caliper to the disc. Make sure the pistons are moving evenly.

    Or, instead of using the sqeeze brake method, align the disc between the pads by sight, using a flashlight.

    Oddest thing, I went to do all this but when I spun the wheel everything was fine.. I'll be taking it out for a spin later today so ill update on my return. Thanks all for ur help.

  6. #6
    mtbr member
    Reputation:
    Join Date
    Aug 2013
    Posts
    9
    Quote Originally Posted by petesman View Post
    Oddest thing, I went to do all this but when I spun the wheel everything was fine.. I'll be taking it out for a spin later today so ill update on my return. Thanks all for ur help.
    Back from the spin and everything is fine. Must have been the new pads getting to grips with things. Also its possible that my wheel quick realise wasn't tight enough. Anyway panic over. Thanks everyone

Similar Threads

  1. Front disc brake rubbing.
    By 123kij in forum Brake Time
    Replies: 32
    Last Post: 6 Days Ago, 06:18 AM
  2. XT double front DR rubbing
    By Spidey2422 in forum Drivetrain - shifters, derailleurs, cranks
    Replies: 0
    Last Post: 05-27-2013, 06:05 PM
  3. SB-66 front derailleur rubbing on frame
    By dutch23 in forum Yeti
    Replies: 9
    Last Post: 02-14-2013, 01:28 PM
  4. Rubbing front brake pad - Formula The One
    By trenchDiggr in forum All Mountain
    Replies: 19
    Last Post: 01-31-2012, 09:25 PM
  5. front derailleur rubbing chain
    By 99xjlove in forum Beginner's Corner
    Replies: 3
    Last Post: 02-25-2011, 10:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •