Results 1 to 5 of 5
  1. #1
    ol' dusty lungs
    Reputation: the sloth's Avatar
    Join Date
    Aug 2007
    Posts
    195

    elixir lever "hyperextending" normal?

    My levers have been like this since day one, so I figure it's normal, but might as well ask anyway because it's kind of annoying...

    I'm using the reach adjustment to put the lever in closer to the bar, but if I push the levers away with a gentle nudge, they stay in the "out" position, as if they hadn't been adjusted. Pulling them back toward the bar snaps them back into the "reach adjusted" position again. Is that normal? I always manage to bump the levers out during riding and have to go hunting for them. Kind of a weird design.


  2. #2
    *****************
    Reputation: Bikinfoolferlife's Avatar
    Join Date
    Feb 2004
    Posts
    12,378
    Normal, deliberate design by Avid. It's supposed to help the lever survive a crash. Also saw somewhere that it's something you can do while the wheel's out so that if you start to pull the lever you have a safety zone before you need to pry your pads apart...
    "...the people get the government they deserve..."
    suum quique

  3. #3
    ol' dusty lungs
    Reputation: the sloth's Avatar
    Join Date
    Aug 2007
    Posts
    195
    Interesting... thanks!

  4. #4
    mtbr member
    Reputation: Ray Lee's Avatar
    Join Date
    Aug 2007
    Posts
    1,177
    Quote Originally Posted by Bikinfoolferlife
    ....Also saw somewhere that it's something you can do while the wheel's out so that if you start to pull the lever you have a safety zone before you need to pry your pads apart...
    Nice, I had never though about that.

  5. #5
    MTBR Member
    Reputation: ncfisherman's Avatar
    Join Date
    Dec 2007
    Posts
    2,783
    It works too. I actually crashed my first day out on some elixir cr brakes(& new bike)...I thought I was feeling it. Anyway, there is a little bit of damage near where the lever attaches, but that feature prevented it from snapping right off. Still running just fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •