Results 1 to 5 of 5

Thread: Brake Issues

  1. #1
    not really an mtbr member
    Reputation: theextremist04's Avatar
    Join Date
    Jul 2008
    Posts
    596

    Brake Issues

    So I crashed today, and in the middle of it my handlebars whipped around with enough force to tear the brake hose at the lever end (Formula Oro K24s.) I made it home, chopped the last inch off, new olive and fittings, put it together, bled it, and...it still didn't work. I tightened all the bolts and did a complete bleed on it twice to no avail. It makes a sound like it's leaking somewhere down near the caliper. Am I thinking right in that the fittings down at the caliper end might be the problem? Any ideas?

  2. #2
    ride hard take risks
    Reputation: dogonfr's Avatar
    Join Date
    Jan 2005
    Posts
    25,589
    Sometimes when one crashes the brakes get all scqewed up from the slamming they get to go through. If your hearing noise at the caliper that would be a good place to start your rebuild. In most cases when the lever gets slammed the master needs the rebuild but nothing is written is stone.
    Formotion Products
    http://www.formot

  3. #3
    not really an mtbr member
    Reputation: theextremist04's Avatar
    Join Date
    Jul 2008
    Posts
    596
    I don't know, because I landed on the other side. I think the MC is okay as well, as I landed on the end of the bars. The only real damage I noticed was the line being pulled out.

  4. #4
    ride hard take risks
    Reputation: dogonfr's Avatar
    Join Date
    Jan 2005
    Posts
    25,589
    Quote Originally Posted by theextremist04
    The only real damage I noticed was the line being pulled out.
    The hose was pulled out from which part??

    Pics are cool.
    Formotion Products
    http://www.formot

  5. #5
    not really an mtbr member
    Reputation: theextremist04's Avatar
    Join Date
    Jul 2008
    Posts
    596
    Well, pics won't mean much now, I put it back together. The hose apparently tried to pull out of the olive and adjustable banjo at the MC end, but the hose itself tore instead. It tore about half an inch from where it actually ended at the MC. What I'm thinking at this point is that the hose pulled out from the fitting at the caliper end, as the factory fitting is just crimped onto the hose.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •