Results 1 to 2 of 2
  1. #1
    Loser
    Reputation: Jisch's Avatar
    Join Date
    Jan 2004
    Posts
    4,814

    Avid mechs - can't pop the pressure foot back in

    I'm having a problem with my rear Avid Mechanical Disc brake. I've read the overhaul directions and it clearly states that the pressure foot can become dislodged, which is how mine looks right now. The issue is that I can't get it to pop back in. When I was looking into it yesterday a piece of spring metal fell out. I think its a piece of the spring that holds the pads in (not the clip that comes with the pads - the one inside the cast part). I don't think that's necessarily related to the foot being popped out, but now when you put the pads in they don't "click" in. I've tried everything to get that foot to pop in, it just won't.

    Ultimately it doesn't matter that much 'cause I just ordered a new one, but if I can easily fix it, I can use it as a back up. Its obviously seen better days. Its been on my bike for 2 hard years - though, I thought I'd get more than just 2 years out of it.

    John
    Big Strings, Big Wheels, The Jisch Blog

  2. #2
    "El Whatever"
    Reputation: Warp's Avatar
    Join Date
    May 2004
    Posts
    18,711
    Quote Originally Posted by Jisch
    I think its a piece of the spring that holds the pads in (not the clip that comes with the pads - the one inside the cast part). I don't think that's necessarily related to the foot being popped out, but now when you put the pads in they don't "click" in. I've tried everything to get that foot to pop in, it just won't.

    John
    Don't sweat it too much. Koolstop pads don't even use the said retention spring. The pads are held in place by the small peg on each of the "pistons" and the slot in the pad's backing plate. The spring provided make them to never loose contact with the pistons and come loose.
    Check my Site

Similar Threads

  1. blast from the past, cut/paste from archived MTB DOC posts
    By ashwinearl in forum XC Racing and Training
    Replies: 12
    Last Post: 02-09-2005, 08:47 AM
  2. Replies: 5
    Last Post: 09-09-2004, 05:08 PM
  3. Avid Mechs Report (Long)
    By Warp in forum Brake Time
    Replies: 8
    Last Post: 07-13-2004, 09:00 AM
  4. new Avid mechs, no power, dragging, squealing
    By dllewell in forum Brake Time
    Replies: 13
    Last Post: 06-22-2004, 10:50 AM
  5. new levers for avid mechs?
    By guava in forum Brake Time
    Replies: 7
    Last Post: 02-22-2004, 11:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •