Results 1 to 1 of 1
  1. #1
    mtbr member
    Reputation: rc-architect's Avatar
    Join Date
    Dec 2007
    Posts
    74

    Avid CR Mag and a dental pic?

    New problem for me. I've had and bled avids for years, today I have found a problem Ive never had before.

    I needed a bleed on my front, bled it using the SRAM updated procedure as I have done before but I wasn't happy with the feel. I opted to rebleed. When I went to bleed the line(15 minutes after 1st bleed) I couldnt push fluid using the syringes in either direction, couldn't push 1 mm. It was as if the cable itself was blocked or crimped off. ( and yes the siringe clamps were open)

    I called SRAM and gave them the problem, they thought maybe the o ring had deteriorated and a piece of it got into and blocked a port and recommended using a dental pic to clean out. I tried this to no avail and my o rings look good anyway.

    Any thoughts? I hate being defeated by a bike component.

    Edit: looks like someone else had a similar issue, but no real answer.
    2009 Avid Elixir CR question


    Thanks
    rc
    Last edited by rc-architect; 09-23-2011 at 07:31 PM.

Similar Threads

  1. Free Dental Work ... Rock Island Style
    By mortman in forum Idaho, Montana, Wyoming
    Replies: 2
    Last Post: 08-13-2008, 02:19 PM
  2. Q tips and dental floss
    By formica in forum Passion
    Replies: 22
    Last Post: 01-12-2008, 09:31 PM
  3. Replies: 47
    Last Post: 01-28-2007, 03:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Can't find it? Just search our site!