Results 1 to 4 of 4
  1. #1
    mtbr member
    Reputation:
    Join Date
    Dec 2007
    Posts
    107

    Avid Code Bleeding issue

    I am having issues with bleeding the brakes. I have the Avid kit and have done this before so thats not the issue. I am unable to do the step where you bleed the line. The lever is no longer held closed and the syringe is open but I am not able to push fluid up to the lever. I have even tried with the lever syringe off and hole open, and even tried to loosen the cap thinking there was something that was causing a back pressure. Its not the line being clogged either as I have removed line from lever and can push fluid out the open end with no problem.

    I know it must have something to do with the lever but what? Any ideas? I am stuck.

  2. #2
    I think I need to Upgrade
    Reputation: AzSpeedfreek's Avatar
    Join Date
    Feb 2004
    Posts
    1,621
    The allen screw adjuster on the lever that adjusts the reach of the lever needs to be screwed in, in other words adjust the screw to bring the lever in closer to the bar in its resting position. More than likely what is happening is the position of the shaft that the lever pushes into the master cylinder is at just the right angle where it is closing or binding the master cylinder piston and not allowing fluid to flow.

  3. #3
    mtbr member
    Reputation: Mark Westin's Avatar
    Join Date
    Aug 2006
    Posts
    32
    I had the same problem when I bled my Code brakes and discovered that the instructions were correct, but that I didn't understand what they were trying to tell me to do. They tell you to turn the red knob (pad contact) "all the way out" which I did. I couldn't make any fluid go from the caliper to the lever. Eventually I tried turning the Red knob all the way the other way (in as I saw it) and I was instantly able to push fluid from the caliper to the lever. I guess that what they mean by "all the way out" is what I thought was "all the way in".

    Mark
    2008 Blue Anodized Chumba XCL
    1985 Red Schwinn Cimarron

  4. #4
    Calm Like a Bomb
    Reputation: pipes10's Avatar
    Join Date
    Mar 2007
    Posts
    2,042
    mark westin is sort of correct...turn the red contact knob all the way out, then turn it one turn in...this should solve your difficulties
    Carbon Wilson
    Carbon Troy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •