Results 1 to 4 of 4

Thread: Avid BB5 help

  1. #1
    mtbr member
    Reputation:
    Join Date
    Jan 2011
    Posts
    216

    Avid BB5 help

    I just got a 2011 Specialized Rockhopper this past Monday, and I am having an issue with the front brakes.

    When I am not riding the bike and just spin the front wheel off the ground everything is fine, but when I actually ride the bike there is a grinding sound that suggests that the pads are dragging on the rotor (the rotor isn't bent).

    So I adjusted the pad spacing (twisted the red knob on the caliper) and the grinding noise is still there. When I look at the spacing of the pads there is 1-2mm of space on the inside pad and 3-4mm of space on the out side pad (but it sits at an angle,one side is .5mm from the rotor).

    Is the out side brake pad on the front supposed to be at an angle (pretty sure this is the problem)? If not how would I fix it?




    I was just gonna bring it to my LBS but if its just something trivial I would rather not bother them.

    Thanks for your help!

  2. #2
    mtbr member
    Reputation:
    Join Date
    Jan 2011
    Posts
    216
    Never mind! It was just something dumb!

  3. #3
    mtbr member
    Reputation:
    Join Date
    Feb 2008
    Posts
    252
    your wheel was in crooked?

  4. #4
    mtbr member
    Reputation:
    Join Date
    Jan 2011
    Posts
    216
    Yeah, that's what the mechanic at my LBS said LOL, that and the pad being slightly angled is normal.

Members who have read this thread: 0

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •