Page 9 of 23 FirstFirst ... 5 6 7 8 9 10 11 12 13 19 ... LastLast
Results 201 to 225 of 570
  1. #201
    mtbr member
    Reputation: bajaguy's Avatar
    Join Date
    Jul 2009
    Posts
    154
    Quote Originally Posted by Lelandjt View Post
    "Mid-October" has come and passed and still no word from KS on what the delays with the 150mm are or when the next shipment will arrive.
    Are you looking for 31.6 or 30.9? Universal cycles has some 31.6's in stock and my LBS had four 30.9 150's in stock a couple days ago. They are out there...

  2. #202
    bike rider
    Reputation: Lelandjt's Avatar
    Join Date
    Feb 2008
    Posts
    4,156
    Thanks for the heads-up. I was looking for a 31.6 all summer but now that bike won't be used till May so I'll wait till spring to get one.
    Keep the Country country.

  3. #203
    FX4
    FX4 is offline
    mtbr member
    Reputation:
    Join Date
    Jun 2012
    Posts
    454
    Quote Originally Posted by waldog View Post
    Question for you all.

    I'm on my second LEV now. Sent the first one back because it had torsional play straight out of the box.

    So, new post, same problem. Not as much, but it's still there.

    How much, if any, play have you all got in your LEVs?

    Such a wad of cash, it's just a bit disappointing that it's like this already.

    Cheers, Grant.
    After reading this entire thread, I'm convinced to wait for the Thomson.

  4. #204
    mtbr member
    Reputation:
    Join Date
    Mar 2004
    Posts
    142
    Quote Originally Posted by Lelandjt View Post
    "Mid-October" has come and passed and still no word from KS on what the delays with the 150mm are or when the next shipment will arrive.
    Just got my "mid-october" post last night. Install was no problem. First test ride is tonight.

  5. #205
    father, mountain biker
    Reputation: shredjunkie's Avatar
    Join Date
    May 2012
    Posts
    193
    I think the honeymoon is over with my KS Lev. One month in and it has started to make a horrible creaking noise in the head, uggh. Anyone else had this issue?

    UPDATE: Pulled apart the head and reassembled, creak is gone. Fingers crossed for now.
    Last edited by shredjunkie; 10-21-2012 at 05:32 PM.
    "He seems quite arrogant and ignores quite some valid points." -Millfox
    "I don't like you" -ne_dan

  6. #206
    mtbr member
    Reputation:
    Join Date
    Jul 2007
    Posts
    213
    Quote Originally Posted by shredjunkie View Post
    I think the honeymoon is over with my KS Lev. One month in and it has started to make a horrible creaking noise in the head, uggh. Anyone else had this issue?

    UPDATE: Pulled apart the head and reassembled, creak is gone. Fingers crossed for now.
    I have got a creak, thought it was my carbon rails, which I cleaned and added fresh carbon paste but will pull off and clean the head assembly and see if that fixes the creak, thanks for the update!

  7. #207
    father, mountain biker
    Reputation: shredjunkie's Avatar
    Join Date
    May 2012
    Posts
    193
    Quote Originally Posted by shiny View Post
    I have got a creak, thought it was my carbon rails, which I cleaned and added fresh carbon paste but will pull off and clean the head assembly and see if that fixes the creak, thanks for the update!
    When I pulled it apart, the bottom plate was slightly out of alignment. Not sure if that was the source of the creak, but couldn't have been helping.
    "He seems quite arrogant and ignores quite some valid points." -Millfox
    "I don't like you" -ne_dan

  8. #208
    mtbr member
    Reputation: Cult Hero's Avatar
    Join Date
    Apr 2007
    Posts
    272
    Just finished installing my 125 and found that the "grappling hook" that hooks in the actuator was rather weak and flimsy. During the install I noticed what one of the arms was bent and not hooking (no idea how that happened) so I GENTLY tried to bend it back. Needless to say it broke off.

    It still is working, but disappointed that the system seems to rely on one tiny piece of fragile material. I understand the idea is to be able to disconnect the seatpost from the bike quickly, but I don't ever really see leaving my bike anywhere long enough for it to be stolen. I would rather see a more permanent attachment that is a little more robust.

    Other suggestion is to make sure the claw, grappling hook whatever is hooked facing out. Secures a lot more effectively. Also I see some people skipping the in line barrel adjustor. I found it critical in getting the right tension.

    Will ride this weekend and see how it works. I have a little lateral movement to the post, but that seems normal. For $400 I guess I would expect a little tighter.

    Anyway still feel this is the best option for me on the market right now. Just waiting for some player to come in and really nail this segment, seems there are far too many designs that are almost perfect, but miss just slightly.
    Last edited by Cult Hero; 10-25-2012 at 09:14 PM.

  9. #209
    mtbr member
    Reputation:
    Join Date
    Mar 2004
    Posts
    142
    Quote Originally Posted by MTBMarkWa View Post
    Just got my "mid-october" post last night. Install was no problem. First test ride is tonight.
    After a week of riding with this post I gotta say I love it so far. I have used just about every dropper post out there. This one replaced a Reverb as I wanted the extra drop on this bike of the Lev 150. Post goes up and down very smoothly, remote works perfectly. Love not having to deal with the cable changing position when changing the seat height. It will now be a matter of longevity. Will it last is the big question. Will post back if anything changes.

  10. #210
    mtbr member
    Reputation:
    Join Date
    Feb 2011
    Posts
    91
    Anyone looking to get a Lev, Bike Bling currently has it on sale for $349 , and with the aditional 15% off i managed to get it for $296.65 before shipping and taxes, though the tax didn't apply to me.

    They had the 125mm in stock when I got it but the 100mm was on back order, dunno about the 150mm

  11. #211
    mtbr member
    Reputation:
    Join Date
    Jul 2007
    Posts
    213
    Quote Originally Posted by shredjunkie View Post
    When I pulled it apart, the bottom plate was slightly out of alignment. Not sure if that was the source of the creak, but couldn't have been helping.
    Well I need to do a few more rides to be sure but creak free so far. Put a dab of grease under the cradle and snugged up the bolts a bit more which seems to have resolved the creak.

    Really liking this post, it is my first dropper and it works flawlessly, I was on the fence and was still undecided after the first few rides but now really like the boost in confidence for jumps and techy terrain that it allows.

  12. #212
    mtbr member
    Reputation:
    Join Date
    Feb 2011
    Posts
    91

    Upset

    Well just got the Lev, installed it and in the middle of testing it, not even on a ride yet!, it fails to drop, removed the cable junction cover and the darn kevlar wire which was held by the coupler has come off, and is all frayed

    ugh now either i send it in to KS or maybe just have them send the replacement wire with that damn isolator which mine wasn't installed with and do it myself
    Last edited by atonyc68; 10-28-2012 at 07:18 PM.

  13. #213
    Prime
    Reputation: Optimus's Avatar
    Join Date
    Apr 2012
    Posts
    4,553
    You got a fluke, atonyc68, KS is pretty good stuff. This my second KS post over the last 2 years, lots of hard usage, only 1 minor problem that KS took care of promptly.

  14. #214
    mtbr member
    Reputation: Creeper's Avatar
    Join Date
    Feb 2009
    Posts
    149
    Quote Originally Posted by atonyc68 View Post
    Well just got the Lev, installed it and in the middle of testing it, not even on a ride yet!, it fails to drop, removed the cable junction cover and the darn kevlar wire which was held by the coupler has come off, and is all frayed

    ugh now either i send it in to KS (who knows how long until i get it back) or maybe just have them send the replacement wire with that damn isolator which mine wasn't intalled with and do it myself

    Anyone else run into this problem yet?
    Been there. Mine did'nt work correctly out of the box. My kevlar cable was too long or it had slipped. It was frayed and the plastic inside the coupler kept me from pulling it through. I actually tried to fix it but broke the coupler trying to tighten it enough not to slip. They suggest priority mail. I shipped from Alabama on Thursday and got it back the following Friday and that included a holiday. Their fast but, it sucks having to pay $13 more to get a post to work correctly that should have worked correctly in the first place. They aren't even sympathetic about it when you call. I believe they could care less. I tried to get them to pay my shipping since it was brand new but, they refused. They use the excuse of "we don't know if you installed it right". I said" fine but if you find it messed up from the factory will you reimburse me?" They said "no". The $13 won't kill me, it's the princple of the matter. It works fine for now but, only ridden twice since I got it back.

  15. #215
    mtbr member
    Reputation:
    Join Date
    Feb 2011
    Posts
    91
    Quote Originally Posted by Optimus View Post
    You got a fluke, atonyc68, KS is pretty good stuff. This my second KS post over the last 2 years, lots of hard usage, only 1 minor problem that KS took care of promptly.
    Ya i know, but still kinda pissed off, was so excited to get out on the trail to test this thing and it fails

    Quote Originally Posted by Creeper View Post
    Been there. Mine did'nt work correctly out of the box. My kevlar cable was too long or it had slipped. It was frayed and the plastic inside the coupler kept me from pulling it through. I actually tried to fix it but broke the coupler trying to tighten it enough not to slip. They suggest priority mail. I shipped from Alabama on Thursday and got it back the following Friday and that included a holiday. Their fast but, it sucks having to pay $13 more to get a post to work correctly that should have worked correctly in the first place. They aren't even sympathetic about it when you call. I believe they could care less. I tried to get them to pay my shipping since it was brand new but, they refused. They use the excuse of "we don't know if you installed it right". I said" fine but if you find it messed up from the factory will you reimburse me?" They said "no". The $13 won't kill me, it's the princple of the matter. It works fine for now but, only ridden twice since I got it back.
    Oh man that sucks, ya worst for me, i'm from canada, bought it in the US when I was there, maybe i'll just get them to send me the replacement parts and then just do it myself

  16. #216
    mtbr member
    Reputation: anvil_den's Avatar
    Join Date
    Nov 2007
    Posts
    940
    Quote Originally Posted by Cult Hero View Post
    Just finished installing my 125 and found that the "grappling hook" that hooks in the actuator was rather weak and flimsy. During the install I noticed what one of the arms was bent and not hooking (no idea how that happened) so I GENTLY tried to bend it back. Needless to say it broke off.

    It still is working, but disappointed that the system seems to rely on one tiny piece of fragile material. I understand the idea is to be able to disconnect the seatpost from the bike quickly, but I don't ever really see leaving my bike anywhere long enough for it to be stolen. I would rather see a more permanent attachment that is a little more robust.
    Fully agree on the hook claw... piece of cheese. Havent broke mine but I wont be fiddling with it more than necessary. Saving grace is that actuator bar it hooks onto needs only a very light action --so that alone at least wont be breaking the claws.

  17. #217
    mtbr member
    Reputation:
    Join Date
    Feb 2011
    Posts
    91
    Hey anyone know the KS post paste they use, can i just use my bearing grease i usually use or does it have to be their paste?

  18. #218
    Mr. Knowitall
    Reputation: hssp's Avatar
    Join Date
    Aug 2007
    Posts
    754
    Quote Originally Posted by atonyc68 View Post
    Hey anyone know the KS post paste they use, can i just use my bearing grease i usually use or does it have to be their paste?
    Use Slick Honey or Slickoleum and nothing else. Other greases will make the post sticky. Trust me.

  19. #219
    bike rider
    Reputation: Lelandjt's Avatar
    Join Date
    Feb 2008
    Posts
    4,156
    Yeah, suspension specific grease. Other bearing greases can mess up the plastic parts.
    Keep the Country country.

  20. #220
    mtbr member
    Reputation: Cult Hero's Avatar
    Join Date
    Apr 2007
    Posts
    272
    anyone know how to get ahold of KS other than their RA form? They seem to want me to send the whole post back, but I just need a new claw..

  21. #221
    mtbr member
    Reputation:
    Join Date
    Feb 2011
    Posts
    91
    Quote Originally Posted by hssp View Post
    Use Slick Honey or Slickoleum and nothing else. Other greases will make the post sticky. Trust me.
    Quote Originally Posted by Lelandjt View Post
    Yeah, suspension specific grease. Other bearing greases can mess up the plastic parts.
    Awesome thanks guys

  22. #222
    mtbr member
    Reputation:
    Join Date
    Feb 2011
    Posts
    91
    Quote Originally Posted by Cult Hero View Post
    anyone know how to get ahold of KS other than their RA form? They seem to want me to send the whole post back, but I just need a new claw..
    Ugh oh man, that might mean i have to send mine back as well, hopefully they can send me just the parts

    found this on their site

    KS USA
    26741 Portola Pkwy Suite 1E658
    Foothill Ranch, CA 92610
    Tel: +1 (949) 742-1180

    Too bad they don't have a toll free number, or do they?

  23. #223
    mtbr member
    Reputation: Cult Hero's Avatar
    Join Date
    Apr 2007
    Posts
    272
    Quote Originally Posted by atonyc68 View Post
    Ugh oh man, that might mean i have to send mine back as well, hopefully they can send me just the parts

    found this on their site

    KS USA
    26741 Portola Pkwy Suite 1E658
    Foothill Ranch, CA 92610
    Tel: +1 (949) 742-1180

    Too bad they don't have a toll free number, or do they?

    Yea, called that number a few times and all I get is vm. Post is working fine, but the claw has one arm. I have two good rides on it now and stoked on how the post is working. I will be dropping the pressure and I bumped it up to get a fast rebound but actually find that a slower rebound helps me fine tune the seat position I am looking for.

  24. #224
    mtbr member
    Reputation:
    Join Date
    Feb 2004
    Posts
    236

    Trials and tribulations

    3 rides on my new 31.6 150mm LEV. Sometimes it won't stay at full drop. Comes back up a couple inches. Does this a few times when cycled down and then seems to catch and be all good. Seems to occur after it hasn't been cycled for a few minutes plus.

    Weird...and disappointing. I had a 900 series for over 2 years with no issues. At least I'm 5 minutes from KS offices, left them a VM today for warranty service.

    UPDATE 1:

    Mea coupa...I wanted to update this as I think I'm to blame here: Today the post wouldn't drop for me. I was pissed. I pulled the red cover and the hook was still attached and it was pulling the internal barrel and kevlar down so i figured something internal was bad. I tightened the barrel adjust as far as it would go and the post finally started to budge. When I got home I shortened the cable and moved the grappling hook closer to the housing (with barrel adjuster all the way in). I think 2 things had happened:

    1) the cable stretched a bit or housing compressed a bit or the cable may have slipped, perhaps I hadn't tightened the set screw on the hook tight enough? That would explain why the post wouldn't drop if their wasn't sufficient tension/cable throw.

    2) I noticed the tip of the cable ferule is supposed to lock into that red cover (like pull the ferule down, insert cover, let ferule up). That little plastic ferule tip was buggered up (even though the red cover was fitting perfect). Maybe that tip was protruding inside enough to interfere with the spring and temporarily slow the cable return enough to let the post come back up a bit before locking? The KS instructions don't give much detail for that ferule tip/cover interface. I wish the ferule was metal to be a bit more robust at the tip.

    I removed the deformed ferule tip and with good cable tension now it seems to be working perfect again. I'll update with more time on it but I didn't want to throw KS under the bus without cause and I wanted to pass along the experience for other users/potential buyers.

    UPDATE 2:

    Product is indeed faulty. Works OK if unweighted or pushing on it by hand when off bike. But keep it weighted and/or try to drop it fast and it locks up solid. Sometimes it wont budge, sometime it drop an inch or so, and sometimes it will drop all the way but then return up a couple inches even when I've released the lever.

    There's absolutely zero cable slop but it's also not overly taught.

    Going back to KS tomorrow under RA. I'm going back to my 2 year old flawless i-950 and selling this POS after warranty.
    Last edited by dodger; 11-07-2012 at 08:14 PM. Reason: More experience

  25. #225
    mtbr member
    Reputation:
    Join Date
    Jul 2007
    Posts
    150
    Quote Originally Posted by dodger View Post
    At least I'm 5 minutes from KS offices, left them a VM today for warranty service.
    You will still have to get an RA and send it in. I am in OC too and had to do this with my Supernatural. The good news is it takes about three days total, door to door to get it back. I really don't know how they turn them around so fast!

    My LEV has had no issues except popping the red cap off and spending 15 minutes looking for it. I just threw a zip tie over it and called it a day! I may try to flip the claw around a remove the zip tie, but so far don't see any reason to.

Page 9 of 23 FirstFirst ... 5 6 7 8 9 10 11 12 13 19 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •