Results 1 to 2 of 2
  1. #1
    mtbr member
    Reputation:
    Join Date
    Apr 2011
    Posts
    3

    Avid G3CS 203 Rotor vibration.

    Hi!

    I have a bike Specialized Hardrock Disck 2011. I've just upgraded my brakes from the mechanical Tektro IO to Avid Elixir 5. I installed 203mm rotors on front and rear. I know it is unusual to put such a big rotor on the rear but I though what the hell...

    So, there was everything fine until the pads braked in. Then all rear side started vibrating when I pulled the rear brake lever. Whereas with the front brake everything was just fine, no sound at all. I checked all the bolts everything was properly tighten. I tried to realign the brake caliper several times but with the same result.

    Then I put my stock 160mm rotor back. And now there is no vibration and everything quiet. Obviously the brake force has decreased.

    Guys, can You tell me where could be the reason of that vibration? Or maybe that is the reason why nobody puts a 203mm rotor on the rear?

    Thanks in advance.
    Cheers!

  2. #2
    T.W.O
    Reputation: pfox90's Avatar
    Join Date
    Aug 2010
    Posts
    1,729
    There is an optimal level in which brakes will run at. The reason you don't see anyone run a 203 in the back is simply because it isn't necessary and may even throw your braking ratio off to where you actually lose power.

    Just put the 160 on. I thought my 203 up front was overkill, $hit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •