Results 1 to 5 of 5
  1. #1
    mtbr member
    Reputation:
    Join Date
    Jan 2006
    Posts
    190

    Paragon sliders or ti bike owners (x-post)

    I recently just built up a new titanium 29er as a single with paragon sliders. When the bike is in the stand no rub. Sitting on the bike while riding=rub. Standing forward like while climbing, little to no rub. And I'm not a big power guy. Has anybody using the paragon sliders on any material or anybody riding a ti disc frame had a problem like this? The same brakes were on my kona and didn't have a problem so I'm assuming it's the new frame. I'm contacting the manufacturer soon, but I wanted to get some community feedback first. thanks

  2. #2
    mtbr member
    Reputation:
    Join Date
    Jan 2004
    Posts
    525

    I.....

    I have Ti frame with sliders and no rubbing issues. Sometime You do need to get fussy with a disc no matter how the bike is made.

  3. #3
    mtbr member
    Reputation:
    Join Date
    Aug 2004
    Posts
    319
    I've been using paragon sliders on a custom steel frame (Quiring) with disks for the last seven months. No rubbing issues here.
    --
    Joe Partridge

  4. #4
    SBK
    SBK is offline
    HMFIC
    Reputation: SBK's Avatar
    Join Date
    Oct 2006
    Posts
    371
    Another Quiring Ti/Paragon/Disc rider here with no rubbing issues...
    Mark
    "Anger is a gift..."

  5. #5
    mtbr member
    Reputation: jfkbike2's Avatar
    Join Date
    Feb 2005
    Posts
    978
    No problems on my Moots or DeSalvo. Both Ti and i am a big guy. Brake setup takes a little time and can need adjusting after first few rides.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •